summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-31 08:12:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-31 08:33:41 +0200
commite1ba5a2821e23bb94678a359414abc0e4cc2324e (patch)
tree3c7390c46f9e5c21db937e2c6d8e3438ec716d12 /dev-python/tiny-proxy
parentdev-python/google-api-python-client: Bump to 2.88.0 (diff)
downloadgentoo-e1ba5a2821e23bb94678a359414abc0e4cc2324e.tar.gz
gentoo-e1ba5a2821e23bb94678a359414abc0e4cc2324e.tar.bz2
gentoo-e1ba5a2821e23bb94678a359414abc0e4cc2324e.zip
dev-python/tiny-proxy: Bump to 0.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tiny-proxy')
-rw-r--r--dev-python/tiny-proxy/Manifest1
-rw-r--r--dev-python/tiny-proxy/tiny-proxy-0.2.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/tiny-proxy/Manifest b/dev-python/tiny-proxy/Manifest
index 4d9159acc16f..3d5ac361927d 100644
--- a/dev-python/tiny-proxy/Manifest
+++ b/dev-python/tiny-proxy/Manifest
@@ -1 +1,2 @@
DIST tiny-proxy-0.1.1.gh.tar.gz 14940 BLAKE2B eba17082bf832127c36468db37d9214e45d236c9c1fa7e357e05269df8671f4a06992e03224147642221220aeb89d91479332038e09bf1aa22ce1f0c0316ff20 SHA512 aaf677d18058e6c7c1133398e03d7b0d8b9b4e500fc89174bb3dda1145eb0382492b227f892f672d7a558a30f1d4b92b20eef62922e0e6983f93fcd17850d825
+DIST tiny-proxy-0.2.0.gh.tar.gz 15017 BLAKE2B 46c98d7d4fff2af85464a7c280d212b9be4eb263b8ca643013166b6a81d8783b3078d1551fba0d40417a0cbab795564dbd457bfc037e6c2d40612eabb45fef01 SHA512 748de443ab337f159b1bce852de7f3f10ca32a5580f99bf1e3448c86f49cba26a6ed2855d06b91da7457b3185f99755efd65714a4db3804309cc931e16bdd8b5
diff --git a/dev-python/tiny-proxy/tiny-proxy-0.2.0.ebuild b/dev-python/tiny-proxy/tiny-proxy-0.2.0.ebuild
new file mode 100644
index 000000000000..00f93dd73e1d
--- /dev/null
+++ b/dev-python/tiny-proxy/tiny-proxy-0.2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple proxy server (SOCKS4(a), SOCKS5(h), HTTP tunnel)"
+HOMEPAGE="
+ https://github.com/romis2012/tiny-proxy/
+ https://pypi.org/project/tiny-proxy/
+"
+SRC_URI="
+ https://github.com/romis2012/tiny-proxy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/anyio-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/anyio-3.6.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/aiohttp-3.8.1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.23.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-socks-0.7.4[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/trustme-0.9.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest