summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-28 08:42:56 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-28 09:00:35 +0200
commit6fd84f5a82a993a714724ffb334d1f441911fdd0 (patch)
tree4a1e668c02dd21b992f4fb93c07061dd597ee879 /dev-python/textdistance
parentdev-python/python-dbusmock: Bump to 0.24.1 (diff)
downloadgentoo-6fd84f5a82a993a714724ffb334d1f441911fdd0.tar.gz
gentoo-6fd84f5a82a993a714724ffb334d1f441911fdd0.tar.bz2
gentoo-6fd84f5a82a993a714724ffb334d1f441911fdd0.zip
dev-python/textdistance: Bump to 4.2.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/Manifest1
-rw-r--r--dev-python/textdistance/textdistance-4.2.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/textdistance/Manifest b/dev-python/textdistance/Manifest
index 4a3aedf10276..811e9e228875 100644
--- a/dev-python/textdistance/Manifest
+++ b/dev-python/textdistance/Manifest
@@ -1 +1,2 @@
DIST textdistance-4.2.1.tar.gz 45095 BLAKE2B c0b7fec8adb3a90fc2f3c939a39492887a4989e16d6bd9c548fceb1d5020323d2782dabdb69ae17dc4c3cd795425b3fbdf9bb6041b1ef7df840c2b3a9e2a7e05 SHA512 daff22077800e42ae266edd8614a1300f3f2d080868dbd38e14d035f19853e555485d27ab0392401318e0c4ddc81fbf1b537dd3aa1ba25d7a89e5f0edde8ce46
+DIST textdistance-4.2.2.tar.gz 45089 BLAKE2B 8b08db743a56c289cc10a9ceb606612acb2a13d12cd12f9627870a4748c415804bde7c3f1aee54d59a49053731727827dbbd5f4ed6c2cfcc302166575ba382ca SHA512 f181686153e6e8f1541a15ac752e6a86698445713732858e63b6465c96dfeb582d2ea6cad1f7c526a3dc60796d58064355480bc6ced7dc69268a5c0abbfabdb7
diff --git a/dev-python/textdistance/textdistance-4.2.2.ebuild b/dev-python/textdistance/textdistance-4.2.2.ebuild
new file mode 100644
index 000000000000..bb2161da9c2f
--- /dev/null
+++ b/dev-python/textdistance/textdistance-4.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Compute distance between the two texts"
+HOMEPAGE="https://github.com/life4/textdistance"
+SRC_URI="
+ https://github.com/life4/textdistance/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/abydos[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/isort[${PYTHON_USEDEP}]
+ dev-python/jellyfish[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/python-levenshtein[${PYTHON_USEDEP}]
+ dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests --install pytest
+
+EPYTEST_DESELECT=(
+ tests/test_external.py
+)