summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-27 08:16:25 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-27 08:16:25 +0200
commit2c340134298431a3cc91be0b09ba5c7a488c2982 (patch)
tree5c56cf0b0e83f213ae86ed2e8a5e6057a6c565b3 /dev-python/textdistance
parentdev-python/mkdocs: Remove old (diff)
downloadgentoo-2c340134298431a3cc91be0b09ba5c7a488c2982.tar.gz
gentoo-2c340134298431a3cc91be0b09ba5c7a488c2982.tar.bz2
gentoo-2c340134298431a3cc91be0b09ba5c7a488c2982.zip
dev-python/textdistance: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/textdistance')
-rw-r--r--dev-python/textdistance/textdistance-4.2.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/textdistance/textdistance-4.2.1.ebuild b/dev-python/textdistance/textdistance-4.2.1.ebuild
deleted file mode 100644
index eea667d2ea26..000000000000
--- a/dev-python/textdistance/textdistance-4.2.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8} )
-
-inherit distutils-r1
-
-DESCRIPTION="Compute distance between the two texts"
-HOMEPAGE="https://github.com/life4/textdistance"
-SRC_URI="https://github.com/life4/textdistance/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-BDEPEND="test? (
- dev-python/abydos[${PYTHON_USEDEP}]
- dev-python/hypothesis[${PYTHON_USEDEP}]
- dev-python/isort[${PYTHON_USEDEP}]
- dev-python/jellyfish[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/python-levenshtein[${PYTHON_USEDEP}]
- dev-python/pyxDamerauLevenshtein[${PYTHON_USEDEP}]
-)"
-
-S="${WORKDIR}/${PN}-v.${PV}"
-
-distutils_enable_tests --install pytest
-
-python_prepare_all() {
- # RuntimeError: cannot import distance.hamming
- # these optional things are missing at the moment
- sed -i -e 's:test_compare:_&:' \
- -e 's:test_qval:_&:' \
- -e 's:test_list_of_numbers:_&:' \
- tests/test_external.py || die
-
- distutils-r1_python_prepare_all
-}