summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 17:16:51 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 18:36:08 +0100
commit3b6125d2a2f2d997bafeb5e011f932d213ce94bd (patch)
treee648b7f0e2cd31269ad8b203f309a154560449a5 /dev-python/textX
parentdev-python/sybil: Bump to 4.0.1 (diff)
downloadgentoo-3b6125d2a2f2d997bafeb5e011f932d213ce94bd.tar.gz
gentoo-3b6125d2a2f2d997bafeb5e011f932d213ce94bd.tar.bz2
gentoo-3b6125d2a2f2d997bafeb5e011f932d213ce94bd.zip
dev-python/textX: Bump to 3.1.0
Closes: https://bugs.gentoo.org/888283 Closes: https://bugs.gentoo.org/889192 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/textX')
-rw-r--r--dev-python/textX/Manifest1
-rw-r--r--dev-python/textX/textX-3.1.0.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/textX/Manifest b/dev-python/textX/Manifest
index eb2765dfa11d..a0be8f7790c1 100644
--- a/dev-python/textX/Manifest
+++ b/dev-python/textX/Manifest
@@ -1 +1,2 @@
DIST textX-3.0.0.gh.tar.gz 1827894 BLAKE2B 1b4dff3919838b8aa27faee9387fafd6771891b730c221e10a5f2593d138634950d6ced5a7344944913d99e591ed87adfac403add582baa50b0b94c9c6498572 SHA512 59b175a3f68b0a5b9b3522e814602c791df3fa7dffb8fabffdeed79ce746ae698ee61c748ce991d8cfee15e094c9437530912e84bdeed4531d0bd96d07477c90
+DIST textX-3.1.0.gh.tar.gz 1822985 BLAKE2B 4418cc98bfe68dcfe1e312a64810819335a1ac55f97661c4c2d9729a988bf70ed34ad710f7c51b1ab7f48f7092460ae79f3756f0566f19dfabac6c2875f2f690 SHA512 a300178990d30b7b0c1a77f48a7d51e9582d51dabc9dfa50dc5195afc1e3b2ce4b0cf6475de815078b460cb564bfb03054154741a50a8d213a0c0eb4cdb5b2ef
diff --git a/dev-python/textX/textX-3.1.0.ebuild b/dev-python/textX/textX-3.1.0.ebuild
new file mode 100644
index 000000000000..2ef355c35dfd
--- /dev/null
+++ b/dev-python/textX/textX-3.1.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Meta-language for DSL implementation inspired by Xtext"
+HOMEPAGE="
+ https://pypi.org/project/textX/
+ https://github.com/textX/textX/
+"
+SRC_URI="
+ https://github.com/textX/textX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/Arpeggio-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cp -a "${BUILD_DIR}"/{install,test} || die
+ local -x PATH=${BUILD_DIR}/test/usr/bin:${PATH}
+
+ # Update the shebang
+ sed -e "s:install/usr/bin/${EPYTHON}:test/usr/bin/${EPYTHON}:" \
+ -i "${BUILD_DIR}"/test/usr/bin/textx || die
+
+ # Install necessary plugins
+ local plugins=(
+ tests/functional/subcommands/example_project
+ tests/functional/registration/projects/*
+ )
+ local p
+ for p in "${plugins[@]}"; do
+ pushd "${p}" >/dev/null || die
+ distutils_pep517_install "${BUILD_DIR}"/test
+ popd >/dev/null || die
+ done
+
+ epytest tests/functional
+}