summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-21 13:00:36 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-21 14:24:53 +0100
commitd4bae5c3dec02da2e6b39600bc80c4ee938b6df8 (patch)
treef7ce622bce53af616011c2b58089d81bb7a48166 /dev-python/termcolor
parentdev-python/moto: Bump to 4.0.10 (diff)
downloadgentoo-d4bae5c3dec02da2e6b39600bc80c4ee938b6df8.tar.gz
gentoo-d4bae5c3dec02da2e6b39600bc80c4ee938b6df8.tar.bz2
gentoo-d4bae5c3dec02da2e6b39600bc80c4ee938b6df8.zip
dev-python/termcolor: Bump to 2.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest1
-rw-r--r--dev-python/termcolor/termcolor-2.1.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index 39e7aad767bd..80578969634c 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1,2 +1,3 @@
DIST python-termcolor-2.1.0.tar.gz 10665 BLAKE2B f3f08d3a490d8e20e5da0b7e639fa0ff780fcdf9c41bce2b962b157437b6880cccace05668e71808598d51eb00a043c9dad4800aaa1f734a931c0a01378ad8f7 SHA512 9dd1b8f1d137fc66d77f26913297a6c82eb25b3fd7ae1c5e639cd023eff02f155363ed5b731ff36bcb4281b7678d8e508fb8430ae0f89fa02b9c219e03f99e8f
+DIST python-termcolor-2.1.1.tar.gz 10831 BLAKE2B 0c5537f81234411ddb117266e45ac7ec8ea0af0f62e08883f4893aec21d83d03534200d1ad1633bed4c57cfd7a83305aaff5af7b0574d948854b7762c9e631f4 SHA512 f652d8ce07e192820c57d62fe76495e81e859a709e61b8a1418985da51a92ce8b71865b362d10331d40a914497fa2bf81e95c924c88ae281663a430ef065ca18
DIST termcolor-2.0.1.tar.gz 9693 BLAKE2B 68592597da70957bd3f03a9a76e546ab17f7c437d00aca53325a617b02c5600679c9912c0ca8d9f7ade03a042cd657e86b1e12a588ec1eeafdfa57f3f5f16372 SHA512 e49f05e587fb420aa373d1644d66e4832a701385fc1da85470fa0d811770f73908ca139e1c1e9cb968cbc74285b038833f371854edc6e20bc22059b31ef1a1ed
diff --git a/dev-python/termcolor/termcolor-2.1.1.ebuild b/dev-python/termcolor/termcolor-2.1.1.ebuild
new file mode 100644
index 000000000000..d29179a49c72
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz -> python-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest