summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-09-15 16:51:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-09-15 16:52:43 -0500
commit63480f30ecb89afa359e363c4b605f3bd07a2dd0 (patch)
tree725eb54e767a655a0bdde92afd1c10e854d01361 /dev-python/tenacity
parentnet-libs/libgsasl: bump to 1.8.1 (diff)
downloadgentoo-63480f30ecb89afa359e363c4b605f3bd07a2dd0.tar.gz
gentoo-63480f30ecb89afa359e363c4b605f3bd07a2dd0.tar.bz2
gentoo-63480f30ecb89afa359e363c4b605f3bd07a2dd0.zip
dev-python/tenacity: 6.2.0 bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-6.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index 033f120522b4..2b5f687809a9 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1 +1,2 @@
DIST tenacity-6.1.0.tar.gz 33438 BLAKE2B e3f7c0ef19f98c0ac5b2a9a1be53241292d895547e5c10810ff94c27f34e8bbca7ef3aea79ce6e4042c84109e209b4be2913e6231233a3b050c18ed52f8af087 SHA512 a8f52f77e066a35c4a35cdd80fe01922613d9f4ca07975aece4a35bc743475f7540bf419e5095eacf94cb248ce33bdd89b46c5e3c5bd5a93bd99a601cf580732
+DIST tenacity-6.2.0.tar.gz 35213 BLAKE2B 830953463ef9d7ee9e99fc0c9d3f55910754f4c2c777110ad8af65b0af186b2aada25ec3d9ae80f266ad9200080db1af70b80bb77f1edc51148001ca49e0bd08 SHA512 3753ab44390810458c559d243bdc5e3c0092a0c2af7eb4e6fa43d5e6e215a58d4bf3ff6e81800db2f517796b501fff038964b424e364ac417ddd3e70b57bc6c8
diff --git a/dev-python/tenacity/tenacity-6.2.0.ebuild b/dev-python/tenacity/tenacity-6.2.0.ebuild
new file mode 100644
index 000000000000..33a571a754a1
--- /dev/null
+++ b/dev-python/tenacity/tenacity-6.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="https://github.com/jd/tenacity"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pbr[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/monotonic-0.6[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/typing/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}