summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 06:34:17 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 07:27:11 +0100
commit0e7db65f14ac5df6e82defce3d40d1b0e90327f4 (patch)
treea22e03977939866752378291697f4846dceb1ca1 /dev-python/tenacity
parentdev-python/pytest-xdist: Bump to 3.2.0 (diff)
downloadgentoo-0e7db65f14ac5df6e82defce3d40d1b0e90327f4.tar.gz
gentoo-0e7db65f14ac5df6e82defce3d40d1b0e90327f4.tar.bz2
gentoo-0e7db65f14ac5df6e82defce3d40d1b0e90327f4.zip
dev-python/tenacity: Bump to 8.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tenacity')
-rw-r--r--dev-python/tenacity/Manifest1
-rw-r--r--dev-python/tenacity/tenacity-8.2.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/tenacity/Manifest b/dev-python/tenacity/Manifest
index 0e1ffa2920c8..a301e8d9f6f1 100644
--- a/dev-python/tenacity/Manifest
+++ b/dev-python/tenacity/Manifest
@@ -1 +1,2 @@
DIST tenacity-8.1.0.tar.gz 37658 BLAKE2B 4f9e2ea44ac0f0ed8b694b0f60e938fadbcf65bd989e9d641f7a40750f499aa9635a70d80e406aa2ebf436ebd37cde0d88e8ecb6cb3436ba755c2d921541c8e8 SHA512 194312e80233d6edcdf30496a355b272a4de4809bbe187948a7ce9c1382958845d12401498569f2b8d4251ede2857317820779f13a65bb2e69dcb97dde9bb501
+DIST tenacity-8.2.0.tar.gz 39842 BLAKE2B 4c7b58654eff79e2b5e7412f5a920dd09df44a7699d6959dd6e1c5ee87a1e74a0c60df28239be6976368859ebabc4ab35e318a71a7ad5861d92da76a516bd721 SHA512 7bb962257200a450a5599309977c895b9e2918a195a2b60c942dad934145e85e64cf1c043e81fe1a4eb5a4a7d4eaeca626a21388297cf0983bdcea22d56553d3
diff --git a/dev-python/tenacity/tenacity-8.2.0.ebuild b/dev-python/tenacity/tenacity-8.2.0.ebuild
new file mode 100644
index 000000000000..2b2710dd1228
--- /dev/null
+++ b/dev-python/tenacity/tenacity-8.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="General-purpose retrying library"
+HOMEPAGE="
+ https://github.com/jd/tenacity/
+ https://pypi.org/project/tenacity/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ if ! has_version "dev-python/typeguard[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_tenacity.py::TestRetryTyping::test_retry_type_annotations
+ )
+ fi
+
+ epytest
+}