summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-08 17:15:16 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-08 18:36:08 +0100
commiteb6a24cae8e256d578299ba275ec15a1d8fb7dc7 (patch)
tree8c54aeb9e7f8932226631464052481ad659ea1a3 /dev-python/sybil
parentdev-python/Nuitka: Bump to 1.4.4 (diff)
downloadgentoo-eb6a24cae8e256d578299ba275ec15a1d8fb7dc7.tar.gz
gentoo-eb6a24cae8e256d578299ba275ec15a1d8fb7dc7.tar.bz2
gentoo-eb6a24cae8e256d578299ba275ec15a1d8fb7dc7.zip
dev-python/sybil: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-4.0.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 4c733f1eb53c..6d145acccb0e 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-4.0.0.gh.tar.gz 50845 BLAKE2B 5c7144ad1dd131f98c48f18cf6770782529a3c86a3f976461f032c9024ef93dc2de3c8bc327421a55a3f505982608e15cdcfe022f964c4fd871bd9de61205d68 SHA512 6cf0422ba856a85ba5dd105481cb2d06eb2ff196aee263a36e7ab44c7d45185df022bd859afc92b3b42dc418142e441f377adda82c0b5b0d1410697b563db994
+DIST sybil-4.0.1.gh.tar.gz 51137 BLAKE2B f18a84a8ee6524c8af2a54ea17d50e04dba90be54bf5345061d2b6ee161de5c19cb8e1a1849f83401ac5a175453a927f2e068129ccaa4707a48509bb0dc73015 SHA512 70db2aae9f8503af8c5ecb65c5d63e928ba81bc7324473b056a6c1cbb4dac9674c34252665e7b28a1134c37190cdb2fd00c37633a68ea4ac61104a12ea744442
diff --git a/dev-python/sybil/sybil-4.0.1.ebuild b/dev-python/sybil/sybil-4.0.1.ebuild
new file mode 100644
index 000000000000..434b487af5d0
--- /dev/null
+++ b/dev-python/sybil/sybil-4.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst_parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest