summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-13 04:57:32 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-13 05:12:23 +0200
commita9cb61cfaa2c13a7608ad3c6d4c3435e654d94f6 (patch)
tree134df57788b0bc0b75e1281ba18e8f191ebdd3c6 /dev-python/sybil
parentdev-python/mkdocs-git-revision-date-localized-plugin: Bump to 1.2.9 (diff)
downloadgentoo-a9cb61cfaa2c13a7608ad3c6d4c3435e654d94f6.tar.gz
gentoo-a9cb61cfaa2c13a7608ad3c6d4c3435e654d94f6.tar.bz2
gentoo-a9cb61cfaa2c13a7608ad3c6d4c3435e654d94f6.zip
dev-python/sybil: Bump to 7.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-7.0.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index f407fb342633..eceb5d95b93f 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1 +1,2 @@
DIST sybil-6.1.1.gh.tar.gz 71447 BLAKE2B 44ced68adfae094454c9dc4ae55b7327fc9d149728ec9f2faafc42057bc9e99572289100e310f16afdde7741841964a365c008fc9a16092d270ce88dfb0d89be SHA512 f14bb09b8886bd17ccd3a56d3dfc8e2ff510ad04f7b9c8deadff826571e36547934af6855e0a6cbed43e0c0767a0f0af8f80afcecf4a8db74b041fae9d84bd5a
+DIST sybil-7.0.0.gh.tar.gz 74678 BLAKE2B 17ff70054211437c1b1d2053c6f3cea78ba6e401310853ce1b8397caf992267338a7f868b33174d5bbba1c54c1709bade7f4474a0bcb2e8a59e6e9a93e308574 SHA512 ebc0300d0d36abf6307f9104887eb5f9daa78fa9a86bb985b3fbeb05ffbf1ed8a682c681a207dcd1ee0cb37b8448567a50c19ca3657f391a58655253798665d4
diff --git a/dev-python/sybil/sybil-7.0.0.ebuild b/dev-python/sybil/sybil-7.0.0.ebuild
new file mode 100644
index 000000000000..e8ed9cd20ff9
--- /dev/null
+++ b/dev-python/sybil/sybil-7.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}