summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-06 04:28:18 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-06 04:30:41 +0200
commit8fbfd323e1bdef5235db8fe2a9a33cbad1b1adfc (patch)
tree12b1b967305825230d5d65e1a148403c2bf60e55 /dev-python/sybil
parentdev-python/hypothesis: Remove old (diff)
downloadgentoo-8fbfd323e1bdef5235db8fe2a9a33cbad1b1adfc.tar.gz
gentoo-8fbfd323e1bdef5235db8fe2a9a33cbad1b1adfc.tar.bz2
gentoo-8fbfd323e1bdef5235db8fe2a9a33cbad1b1adfc.zip
dev-python/sybil: Bump to 1.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-1.4.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 814f2ae9b58e..8307144e5a43 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,2 +1,3 @@
DIST sybil-1.3.0.tar.gz 29296 BLAKE2B a7f08f6374e12213b644685276832eca849c85e85c8aaf0a37bdfdbf648e0e0e4c2b3d1a4dc7038c91fe8d64aa476d96bf87fa3a5f2f11a955b758182411763d SHA512 fc478896bb1958303ffcac6d35993b2785a50c6c221848d83c92c158a27fff059491aa3baaddd0b56e040fe6c07b764aa33c69204750de9ad351084b2815fd47
DIST sybil-1.3.1.tar.gz 29392 BLAKE2B a7736bed59e444bcd42f5fdf720e08680d827eef9043b318abda08d427e25eeec9ba3acf9bfa251c584e0960c3d3b10fecaf8367742f29230421bec594cf3e59 SHA512 7bd39707babb15ed7ec99ecd640d983d4e71519efe7490230fe0be4e0111bc0b0957797b19292519b6c09965669251788f1d2c0baf9f179856f28e6aeb5ecc52
+DIST sybil-1.4.0.tar.gz 30062 BLAKE2B 86a01b4c8c10512f3e2b067f4d1007e60ba46f23f22ad80ff7a30a4503db06fd91d841b33bc54f0f7acbd2539e595f8b0201f9a8e8ccb7577f8e9f422562e02d SHA512 f385b4e67cc5a4b32c7563d98f36dab6e5320966563eb341395e9327c16f92a63863558bfa795b6531819fa6038234492d4d19c1d9286e6306039e8d4abec0b8
diff --git a/dev-python/sybil/sybil-1.4.0.ebuild b/dev-python/sybil/sybil-1.4.0.ebuild
new file mode 100644
index 000000000000..3918a42c35cd
--- /dev/null
+++ b/dev-python/sybil/sybil-1.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="https://github.com/cjw296/sybil"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# nose is used to test nosetests integration
+BDEPEND="
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest