summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-23 15:34:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-23 15:34:12 +0100
commit31c40ed8fa73d504b9730bfceaab993599fa6d34 (patch)
tree71b824d8af12ff16ab2652549a530f7d7dc3e3b1 /dev-python/sybil
parentdev-python/fonttools: Bump to 4.45.1 (diff)
downloadgentoo-31c40ed8fa73d504b9730bfceaab993599fa6d34.tar.gz
gentoo-31c40ed8fa73d504b9730bfceaab993599fa6d34.tar.bz2
gentoo-31c40ed8fa73d504b9730bfceaab993599fa6d34.zip
dev-python/sybil: Bump to 6.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sybil')
-rw-r--r--dev-python/sybil/Manifest1
-rw-r--r--dev-python/sybil/sybil-6.0.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sybil/Manifest b/dev-python/sybil/Manifest
index 8103cfbfccfe..fc1a2778c110 100644
--- a/dev-python/sybil/Manifest
+++ b/dev-python/sybil/Manifest
@@ -1,3 +1,4 @@
DIST sybil-5.0.3.gh.tar.gz 56660 BLAKE2B 99af245f765630523ab2c6cb21452a0c3a970109102900530f5528ac0902d0472ceb09778bd266e9071816de1da397480e53220a974c5cc38f40367d552cef5e SHA512 0e2a96457b506558b4e9c58890a370c63dbde2c36780dd031cfe8de828f15a2f790c55df81d86800599302958006e704e627b7e8a5d3dd786398ce5f8ea46d35
DIST sybil-6.0.0.gh.tar.gz 67505 BLAKE2B b7408802d5f6796701603762f1e48dbd2f218b5ae80fad940f1ba1fdf0643d1f16cb0a88d94b6385f6ff47d4ab18463be613f736613fa5f0baa3f9ff056ebfa8 SHA512 a03cb7e874a6a41f41ca21e9110f0b8f0d45bb94a5cd7c4f0eb0528ce01db4ac9ca6d8d84663d8851c01dda5da3cb232bcadb33594c5c10e5775f390db37ee9a
DIST sybil-6.0.1.gh.tar.gz 67593 BLAKE2B 443881e81da6456f0790929556334513a8e50d54a0053ddb88b07e29e736e9429ea59fdc30b2d7ff7bdf7e1ec9e272864568aa64fb20a52377d0ee0b39ce30aa SHA512 e71f06744ff07f973ac7f131cd58d4df3697b1cf42a5983b9a93b657d9bfc9358084dcdec00de624b5e89ffa518e64d45591bf616fb53f5e4659ff9755893cd9
+DIST sybil-6.0.2.gh.tar.gz 67619 BLAKE2B ec723cb21d2ac1232bd6e9a3e3edb0bc65c705048c2d288df778b4dd19a1b46c956f7d2bd57dfa028d7a8a06357501ffc1226ba171e2073abec51f8d3c536d86 SHA512 9966173b5fb013be1f298b586052d8c10b76efb43bf5230f3d0b780e6d6238e7e33840eeb7c8b9860911351ea612766ed19ea2a61d48424465f3b58e408da5d2
diff --git a/dev-python/sybil/sybil-6.0.2.ebuild b/dev-python/sybil/sybil-6.0.2.ebuild
new file mode 100644
index 000000000000..38d5f40dd52e
--- /dev/null
+++ b/dev-python/sybil/sybil-6.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Automated testing for the examples in your documentation"
+HOMEPAGE="
+ https://github.com/simplistix/sybil/
+ https://pypi.org/project/sybil/
+"
+# tests are missing in sdist, as of 5.0.1
+SRC_URI="
+ https://github.com/simplistix/sybil/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/seedir[${PYTHON_USEDEP}]
+ dev-python/testfixtures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest