summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-03-04 23:21:06 +0100
committerSebastian Pipping <sping@gentoo.org>2020-03-04 23:22:52 +0100
commit22b1f40c44e0871fdfae2083dc688f571de97153 (patch)
treef884eb8dcd5fec450897c7b4bd717606551fd7df /dev-python/svgwrite
parentnet-mail/notmuch: Fix error on configure with 'crypt' flag disabled (diff)
downloadgentoo-22b1f40c44e0871fdfae2083dc688f571de97153.tar.gz
gentoo-22b1f40c44e0871fdfae2083dc688f571de97153.tar.bz2
gentoo-22b1f40c44e0871fdfae2083dc688f571de97153.zip
dev-python/svgwrite: 1.3.1 + py38 + QA fixes
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'dev-python/svgwrite')
-rw-r--r--dev-python/svgwrite/Manifest1
-rw-r--r--dev-python/svgwrite/files/svgwrite-1.3.1-fix-tests-py38.patch39
-rw-r--r--dev-python/svgwrite/svgwrite-1.3.1.ebuild27
3 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/svgwrite/Manifest b/dev-python/svgwrite/Manifest
index a084815d7413..6eb806cc05f1 100644
--- a/dev-python/svgwrite/Manifest
+++ b/dev-python/svgwrite/Manifest
@@ -1,2 +1,3 @@
DIST svgwrite-1.1.12.tar.gz 202920 BLAKE2B a2b60f3c3829203342919bc75d01f64515f13ba305f357fa788c3754679451e21a7ab97eb517413d4e882e7271d063e7034a10bb70a1946d84734e23e838bdd1 SHA512 326fcc0dd0749925c0c35793a91ffdb25be1fd724d7d87bd6491a6396a6ab65fce073a387faac4f3d034ceadcf24ef73e3838cd249c4e1c19e20b1e82769cf1a
DIST svgwrite-1.2.1.tar.gz 207371 BLAKE2B 8d6198dbfbc9230eb1592651bde3daaf3f14570aa57fb5b0a3e0989b36b76181bfeac9ee96ee7dcf0ad6e53d1e4ec7035e66d2d1f45ef92de59fa0305f391923 SHA512 8874a25ce5418dc86b0f7034555aca46619c415ec6c51243d713f168f9255ddec8d17ecde13cbfe1a4ffcfbad5b160db62d226b5b0106725dd263763d43abdc2
+DIST svgwrite-1.3.1.tar.gz 249712 BLAKE2B 3f03f841d4e1bdf3e8d3d47c86301bcc22f205d71d265902f0ccb5a78710815521f34589ce261a463d7e80c6eeaac60d2090895ae1157ab6f20c0f5c21f5e2e2 SHA512 a4d2db34194923055c6e92c0af5540eef767cf8481d7c991b357f5bc77fd1874bba65220e7a7ff3a4da4bd30a49663b6ac514adb2b41cb4b087a7bb64053ac0a
diff --git a/dev-python/svgwrite/files/svgwrite-1.3.1-fix-tests-py38.patch b/dev-python/svgwrite/files/svgwrite-1.3.1-fix-tests-py38.patch
new file mode 100644
index 000000000000..872a113a2a3d
--- /dev/null
+++ b/dev-python/svgwrite/files/svgwrite-1.3.1-fix-tests-py38.patch
@@ -0,0 +1,39 @@
+From 36ec11ccf3275c6ab9156625d322def9c324e090 Mon Sep 17 00:00:00 2001
+From: mozman <me@mozman.at>
+Date: Wed, 6 Nov 2019 05:24:45 +0100
+Subject: [PATCH] ignore svg tag at pretty print testing
+
+Order of svg attribute of the svg tag has changed in Python 3.8,
+ignoring this tag is the easiest way to solve this problem.
+---
+ tests/test_pretty_xml.py | 3 ++-
+ tox.ini | 2 +-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/tests/test_pretty_xml.py b/tests/test_pretty_xml.py
+index c004626..14a826e 100644
+--- a/tests/test_pretty_xml.py
++++ b/tests/test_pretty_xml.py
+@@ -16,7 +16,8 @@ class TestPrettyXML(unittest.TestCase):
+ def test_pretty_print(self):
+ result = pretty_xml(XML_UGLY).split('\n')
+ expect = XML_PRETTY.split('\n')
+- for e, r in zip(expect, result):
++ # skip svg tag, order of attributes changes often by new Python releases
++ for e, r in zip(expect[1:], result[1:]):
+ self.assertEqual(e, r)
+
+ def test_empty_string(self):
+diff --git a/tox.ini b/tox.ini
+index 55de9ce..fe450be 100644
+--- a/tox.ini
++++ b/tox.ini
+@@ -4,7 +4,7 @@
+ # and then run "tox" from this directory.
+
+ [tox]
+-envlist = py36, py37, pypy
++envlist = py36, py37, py38, pypy
+
+ [testenv]
+ commands = pytest tests
diff --git a/dev-python/svgwrite/svgwrite-1.3.1.ebuild b/dev-python/svgwrite/svgwrite-1.3.1.ebuild
new file mode 100644
index 000000000000..77b8babdc570
--- /dev/null
+++ b/dev-python/svgwrite/svgwrite-1.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Python Package to write SVG files"
+HOMEPAGE="https://github.com/mozman/svgwrite"
+SRC_URI="https://github.com/mozman/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-tests-py38.patch
+)
+
+distutils_enable_tests pytest