summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-10-01 17:12:56 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-10-01 17:29:43 -0500
commit24ce286aaf0d67e986ae9a1277b72b2770e49b00 (patch)
treefafef7871f2fbc970a4a9b481ef6e51d4a1c4b2e /dev-python/stormpath
parentsys-block/blktrace: fix rename from bad PR. (diff)
downloadgentoo-24ce286aaf0d67e986ae9a1277b72b2770e49b00.tar.gz
gentoo-24ce286aaf0d67e986ae9a1277b72b2770e49b00.tar.bz2
gentoo-24ce286aaf0d67e986ae9a1277b72b2770e49b00.zip
dev-python/stormpath: add version 2.4.5
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-python/stormpath')
-rw-r--r--dev-python/stormpath/Manifest1
-rw-r--r--dev-python/stormpath/stormpath-2.4.5.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/stormpath/Manifest b/dev-python/stormpath/Manifest
index 97f20a84082f..dd9de5c5a160 100644
--- a/dev-python/stormpath/Manifest
+++ b/dev-python/stormpath/Manifest
@@ -1,3 +1,4 @@
DIST stormpath-2.4.1.tar.gz 4345634 SHA256 5c07c27ff08527920878e7a350bd6532198e066badf929d70d46937684399e64 SHA512 50fbe12015b3dcc70c13de65d0a594684bb605f24f3aaf60bb51b7ff9e01346e6dece994ebccf790e58fe66c90aad252c4ef4c33b24f1b98172e1634fb733b95 WHIRLPOOL 332080e7c6c2ec7535e8eb51e132ac3df7f18fc65565e25b769f25cd5cd7d65c4b1d28da0c2b186250d8b58b6618bb5b27ccd1c1e6148365ad1139c7d5d39f4f
DIST stormpath-2.4.2.tar.gz 4345932 SHA256 17fb42c24c39830bb39589eff757e3b5c9d09d74c88dba520fa1031b5785e3ff SHA512 0b63308f179f83e409c24dabd75b96b0384b0eae4f729c1351e16c1158a61548c218e94e6d68fab196b6166e67a9132173205d52d03af334d690315f7756efff WHIRLPOOL 536a5899ba68788cd8a4b7c1acebf5126a301e52643da3e66fa7bd26f23b38c3a58adf271db03fa1eb92332c4bac83a4cb434027684c7b46ee53c1de5d69eaca
DIST stormpath-2.4.4.tar.gz 4347668 SHA256 6630abba74bc5de5f295b78fd1c32a60a9d1f3b09863ce4353ea568a99fc175c SHA512 41c06dc8c96f363493777e4d65a559d12af0b4fc85e5bdd1a799d7191f24d06e4c1bad5364771e5aff5788e896a4d8bc5dd9209243f558062444da5201e21747 WHIRLPOOL a9277465fb21d127c7b75f4836ee89b5c98203b68af12b46bb9cb82842a79c7f8c6fc82533b677bd2815d8e5d88007ea44dc82cc8c40af3fe2fbca5883a2cb89
+DIST stormpath-2.4.5.tar.gz 3821801 SHA256 93446387a369483d219db9a1f760743fe97c19fe09f1a1ab6c074f576ff31f22 SHA512 8bf3ad45cabd9c16a615f3303a4253d7f81bfb39a9c1542bc9662be54075f85013624e9ace7ec6ae7a81ef3ebb6864919458bbeca685879a8623ab7fb13cfbb4 WHIRLPOOL ebff05e9bc7346a034d8c3ae643fa65629e29425db7067d8a995b7b63fd8c24d3c987134a03f9bb1817c783a636fa7a5987bdf47d81f7330db0ee9704be6a062
diff --git a/dev-python/stormpath/stormpath-2.4.5.ebuild b/dev-python/stormpath/stormpath-2.4.5.ebuild
new file mode 100644
index 000000000000..82cb332bb003
--- /dev/null
+++ b/dev-python/stormpath/stormpath-2.4.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Official Stormpath SDK, used to interact with the Stormpath REST API."
+HOMEPAGE="https://github.com/stormpath/stormpath-sdk-python"
+SRC_URI="https://github.com/stormpath/${PN}-sdk-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ <=dev-python/oauthlib-1.0.3[${PYTHON_USEDEP}]
+ >=dev-python/pydispatcher-2.0.5[${PYTHON_USEDEP}]
+ >=dev-python/pyjwt-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.6.1[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ esetup.py docs
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}