summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-04-01 13:30:18 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-04-01 13:50:03 -0400
commit8200741ceab7d593e6a92e91877a18a714661d03 (patch)
treed494cc079754aca8bfc3b3e4b1022c1eea6e435a /dev-python/sqlparse
parentdev-python/django: bump to 2.1.8 (diff)
downloadgentoo-8200741ceab7d593e6a92e91877a18a714661d03.tar.gz
gentoo-8200741ceab7d593e6a92e91877a18a714661d03.tar.bz2
gentoo-8200741ceab7d593e6a92e91877a18a714661d03.zip
dev-python/sqlparse: new package
Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/sqlparse')
-rw-r--r--dev-python/sqlparse/Manifest1
-rw-r--r--dev-python/sqlparse/metadata.xml16
-rw-r--r--dev-python/sqlparse/sqlparse-0.3.0.ebuild25
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/sqlparse/Manifest b/dev-python/sqlparse/Manifest
new file mode 100644
index 000000000000..8de093a571b3
--- /dev/null
+++ b/dev-python/sqlparse/Manifest
@@ -0,0 +1 @@
+DIST sqlparse-0.3.0.tar.gz 64072 BLAKE2B fbee74c7222fa50c5d627959d5c8652dcd85ab5b5b771e3c8375cadc6e009c2fb1adc3c2428e27d769c210e7976c350bfab367cb7aa44dd7b4183ad9722a4ca6 SHA512 596d25f5fa2c797fe5652e36e9633397e7867586ff0959f52d1ff861c16d0e7c73644daf03d74169dd20255e802b7369d4dace0a44a3d94c15bd67faa41df551
diff --git a/dev-python/sqlparse/metadata.xml b/dev-python/sqlparse/metadata.xml
new file mode 100644
index 000000000000..b650fb79cb7e
--- /dev/null
+++ b/dev-python/sqlparse/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vdupras@gentoo.org</email>
+ <name>Virgil Dupras</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sqlparse</remote-id>
+ <remote-id type="github">andialbrecht/sqlparse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sqlparse/sqlparse-0.3.0.ebuild b/dev-python/sqlparse/sqlparse-0.3.0.ebuild
new file mode 100644
index 000000000000..17294f018af1
--- /dev/null
+++ b/dev-python/sqlparse/sqlparse-0.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="https://github.com/andialbrecht/sqlparse"
+SRC_URI="https://github.com/andialbrecht/sqlparse/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest )"
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}