summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/sphinxcontrib-doxylink
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/sphinxcontrib-doxylink')
-rw-r--r--dev-python/sphinxcontrib-doxylink/Manifest1
-rw-r--r--dev-python/sphinxcontrib-doxylink/metadata.xml14
-rw-r--r--dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.3.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-doxylink/Manifest b/dev-python/sphinxcontrib-doxylink/Manifest
new file mode 100644
index 000000000000..b454aaab54e3
--- /dev/null
+++ b/dev-python/sphinxcontrib-doxylink/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-doxylink-1.3.tar.gz 12401 SHA256 95dd12637b2d28aae50f2abbf57dcb339be01f7b829dc435432d314a8f37a9c4 SHA512 5a53061cddda22b682b4b640725d4cd763b54d9dfa3599b666dd55d72660f07fc89318abeab07d114d01313b215e69e421a3b5251125d28c3dd326426830f9ee WHIRLPOOL 6db488051e0b2758182a1be6f21601500f473974a1d780e986a7347dceac8f441744c29ded49312021947bd623421237d36f395aac285ff0acba01b78e715f68
diff --git a/dev-python/sphinxcontrib-doxylink/metadata.xml b/dev-python/sphinxcontrib-doxylink/metadata.xml
new file mode 100644
index 000000000000..229aef6d540e
--- /dev/null
+++ b/dev-python/sphinxcontrib-doxylink/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>aballier@gentoo.org</email>
+ <name>Alexis Ballier</name>
+ <description>Python team can take the package if they wish.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-doxylink</remote-id>
+ <remote-id type="bitbucket">birkenfeld/sphinx-contrib</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.3.ebuild b/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.3.ebuild
new file mode 100644
index 000000000000..e3096cd5e8e5
--- /dev/null
+++ b/dev-python/sphinxcontrib-doxylink/sphinxcontrib-doxylink-1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extension to link to external Doxygen API documentation"
+HOMEPAGE="https://pypi.python.org/pypi/sphinxcontrib-doxylink https://pythonhosted.org/sphinxcontrib-doxylink/ https://bitbucket.org/birkenfeld/sphinx-contrib"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+
+RDEPEND="
+ >=dev-python/sphinx-1.0[${PYTHON_USEDEP}]
+ dev-python/pyparsing[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ # any better idea ?
+ rm -rf tests
+ distutils-r1_src_prepare
+}