summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-02 15:46:28 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-02 16:16:34 +0100
commit23a45d0b28fbd04631953a1b6df7c1e46f743c5a (patch)
tree77b2f9cb1cebfdecb93c4b03ec06903432b84fb0 /dev-python/sphinxcontrib-devhelp
parentdev-python/sphinxcontrib-applehelp: Bump to 1.0.2, add tests (diff)
downloadgentoo-23a45d0b28fbd04631953a1b6df7c1e46f743c5a.tar.gz
gentoo-23a45d0b28fbd04631953a1b6df7c1e46f743c5a.tar.bz2
gentoo-23a45d0b28fbd04631953a1b6df7c1e46f743c5a.zip
dev-python/sphinxcontrib-devhelp: Bump to 1.0.2, add tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinxcontrib-devhelp')
-rw-r--r--dev-python/sphinxcontrib-devhelp/Manifest1
-rw-r--r--dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-devhelp/Manifest b/dev-python/sphinxcontrib-devhelp/Manifest
index 64e1635092e3..d995246c268c 100644
--- a/dev-python/sphinxcontrib-devhelp/Manifest
+++ b/dev-python/sphinxcontrib-devhelp/Manifest
@@ -1 +1,2 @@
DIST sphinxcontrib-devhelp-1.0.1.tar.gz 14016 BLAKE2B 4b8c079773d65f5fb752870dc728d8e90e03fdd2f8a4b01324838928ef2deaf2c724c0b149697a61624ea7382445e81fe261ec2b726fa3cfb5547bd053286e4e SHA512 135d6405e330cc245391646d4055988cf762d82f6473e58c64a76f3a88e7f33a66baba366e7f29e1378320bd0c374af92b0f972bceeec8c05ad0fe652a81e984
+DIST sphinxcontrib-devhelp-1.0.2.tar.gz 17398 BLAKE2B fcf04148bc4a77963517d9011c20a6b77eee499f1a5dcd4a9631b4f415f80a9f7091b254f74ba2fbc9b7106dfb741dc839e14813e088d5a0802793ed457e95df SHA512 83b46eaf26df3932ea2136cfda1c0fca4fc08ce8bca564845b3efe5bb00d6c8c93991f4edd4913d4ec796e2d85bd2c7265adf28e98f42e8094daeb5ac11a0eb1
diff --git a/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.2.ebuild b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.2.ebuild
new file mode 100644
index 000000000000..8500fe53feb4
--- /dev/null
+++ b/dev-python/sphinxcontrib-devhelp/sphinxcontrib-devhelp-1.0.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension which outputs Devhelp documents"
+HOMEPAGE="https://www.sphinx-doc.org
+ https://github.com/sphinx-doc/sphinxcontrib-devhelp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+
+RDEPEND="dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]"
+PDEPEND="
+ >=dev-python/sphinx-2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${PDEPEND} )"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${ED}" -name '*.pth' -delete || die
+}