summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-10 07:55:51 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-10 08:32:42 +0100
commite886ce037048406507d3a5cf897eca40d66c2662 (patch)
treeaf10a0a805a8de97c21f33397c99a3546d2ab915 /dev-python/sphinx-notfound-page
parentdev-python/google-api-python-client: Bump to 2.30.0 (diff)
downloadgentoo-e886ce037048406507d3a5cf897eca40d66c2662.tar.gz
gentoo-e886ce037048406507d3a5cf897eca40d66c2662.tar.bz2
gentoo-e886ce037048406507d3a5cf897eca40d66c2662.zip
dev-python/sphinx-notfound-page: Bump to 0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sphinx-notfound-page')
-rw-r--r--dev-python/sphinx-notfound-page/Manifest1
-rw-r--r--dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/sphinx-notfound-page/Manifest b/dev-python/sphinx-notfound-page/Manifest
index 3198e87693fb..ff3a784b7248 100644
--- a/dev-python/sphinx-notfound-page/Manifest
+++ b/dev-python/sphinx-notfound-page/Manifest
@@ -1 +1,2 @@
DIST sphinx-notfound-page-0.7.1.gh.tar.gz 50670 BLAKE2B b438413585fce3623451015d873242de3e6d7c466aa06b0b6398d7e337d2a0d3c2041973b1f1c8491b1f382d8e87a2da00b6a97e3a857b60cb345e715d2aa27b SHA512 f2894b19f8ccee22ac7f6e3a34f8270923e8cc4b2182d490e6ec46477460555de9b67b0075f74cc089b0b9e7474c6db9373d107d272d161d98a3c5609edfa7a0
+DIST sphinx-notfound-page-0.8.gh.tar.gz 57650 BLAKE2B e57634ba9a7faf81e6ee8d9b082d96742b580606f2e2fd559842049ba2e80bcb44bb6bd7a9c7eed6038e4c3ddb0416e32fceb4d47a72b8a600443e0020ff33d6 SHA512 eeb5b8da24ecb8f9814540a126f08204ae623705068608c2ee32a4f90303bdaab5f3934bdc36dd06dff047beb0225603f8cfc9b736769836385837047a36a674
diff --git a/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.ebuild b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.ebuild
new file mode 100644
index 000000000000..67ffc6d4279c
--- /dev/null
+++ b/dev-python/sphinx-notfound-page/sphinx-notfound-page-0.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Create a custom 404 page with absolute URLs hardcoded."
+HOMEPAGE="https://sphinx-notfound-page.readthedocs.io/"
+# PyPI tarballs lack tests
+# https://github.com/readthedocs/sphinx-notfound-page/pull/110
+SRC_URI="
+ https://github.com/readthedocs/sphinx-notfound-page/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+
+RDEPEND="dev-python/sphinx[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest