summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-05 15:48:01 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-05 19:05:38 +0200
commit324f54f3e307064d2081387870a112eb16b7ab41 (patch)
treed91764c2b21b7e0c7bd20509db6df295daefaa6a /dev-python/six
parentdev-python/pytest: Enable python3.10 (diff)
downloadgentoo-324f54f3e307064d2081387870a112eb16b7ab41.tar.gz
gentoo-324f54f3e307064d2081387870a112eb16b7ab41.tar.bz2
gentoo-324f54f3e307064d2081387870a112eb16b7ab41.zip
dev-python/six: Deselect failing pypy3 test
Closes: https://bugs.gentoo.org/728778 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/six')
-rw-r--r--dev-python/six/six-1.15.0-r1.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/six/six-1.15.0-r1.ebuild b/dev-python/six/six-1.15.0-r1.ebuild
index 75bae387ec4c..830bec098c8c 100644
--- a/dev-python/six/six-1.15.0-r1.ebuild
+++ b/dev-python/six/six-1.15.0-r1.ebuild
@@ -17,3 +17,12 @@ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 s
distutils_enable_sphinx documentation --no-autodoc
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=()
+ [[ ${EPYTHON} == pypy3 ]] && deselect+=(
+ 'test_six.py::test_move_items[dbm_ndbm]'
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}