summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-24 11:03:53 +0000
committerSam James <sam@gentoo.org>2022-11-24 11:04:25 +0000
commit3d0ad7d15b6681afa1206db2fb3f0fbf0c4678d1 (patch)
tree93ad9b3cc1c7ed72f6b2d886d003a4ad822b78d0 /dev-python/sip
parentdev-lisp/sbcl: remove old version (diff)
downloadgentoo-3d0ad7d15b6681afa1206db2fb3f0fbf0c4678d1.tar.gz
gentoo-3d0ad7d15b6681afa1206db2fb3f0fbf0c4678d1.tar.bz2
gentoo-3d0ad7d15b6681afa1206db2fb3f0fbf0c4678d1.zip
dev-python/sip: add 6.7.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/sip')
-rw-r--r--dev-python/sip/Manifest1
-rw-r--r--dev-python/sip/sip-6.7.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/sip/Manifest b/dev-python/sip/Manifest
index 77c141217679..cac6abe3e411 100644
--- a/dev-python/sip/Manifest
+++ b/dev-python/sip/Manifest
@@ -1,3 +1,4 @@
DIST sip-4.19.25.tar.gz 1056384 BLAKE2B f92e105e6b30e871aea2883dc9cd459e4032fb139a9eaff153a3412a66b39df4d7ac985711a2693aee83195ff3850ae648bee4102f7fc3cc30d09885799f2b98 SHA512 60fb4133c68869bf0993144978b4847d94a0f9c7b477f64a346ea133cfe35bc11820204ab327dcf9a929b6f65a26d16cc7efbce65e49967c3347b39376e57001
DIST sip-6.6.2.tar.gz 1143535 BLAKE2B 92158af35be47a7581b71d97d1d79f6ca9022144144e3e44e09ccbfa3a285ebb4cec1264e621275159345c33f0f45c86183f7ea1fb3792aca2aeb64d9e46f7ad SHA512 5e031baa9ff6d8d19f4c36ef7c3900c6440d261102259cdc12fce28471a849fed80c123bf31ad506b099a925b2967eb5863e6736ac00fbcff99198711cf0e5e5
DIST sip-6.7.4.tar.gz 1160740 BLAKE2B 35cd2b3c084977083cfc6a7dfcfa48704adab63fef099aa3651c61efc249a79abe63662c3925327ffc1b92273aabe0867119e20e4e3412b217ed76019089a731 SHA512 a3278a89eab0d0e8bf78617a1abfaae9c035b7932f169cc74cf6be0656531c47dd23e9ea6409a03cb7a494ef965f124c29387c72c3a9664a4e54d29163625fb4
+DIST sip-6.7.5.tar.gz 1160691 BLAKE2B 64572687e026854c3e8ba7de637925f13a880e51e574993e37190b9b1fafa1850da686600a652bab9d399f58516e2c4e4d8a93f5fb13d53a12ecc5ec3885a98c SHA512 2dc38a6c0489e374a016b7db1f9443bb5d2fb29dc1fa7647ed2dd5bb4aa8758586e2b85569f9fb3b992e15eded0f7a783ec1a53b3d18bee3f8be53d43b79b7b9
diff --git a/dev-python/sip/sip-6.7.5.ebuild b/dev-python/sip/sip-6.7.5.ebuild
new file mode 100644
index 000000000000..77c031e024db
--- /dev/null
+++ b/dev-python/sip/sip-6.7.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python bindings generator for C/C++ libraries"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/ https://pypi.org/project/sip/"
+
+MY_P=${PN}-${PV/_pre/.dev}
+if [[ ${PV} == *_pre* ]]; then
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+fi
+S=${WORKDIR}/${MY_P}
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="5"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/sip-4.19.25-r1[${PYTHON_USEDEP}]
+ !=dev-python/sip-5.5.0-r0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx doc --no-autodoc