summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-24 08:29:07 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-24 08:59:05 +0200
commit4365ff2aace8b178624ca84a0a26a6aac4615d83 (patch)
treef5469bd51924600070121618db74d8988f0b6493 /dev-python/simplejson
parentdev-python/pebble: Bump to 4.6.2 (diff)
downloadgentoo-4365ff2aace8b178624ca84a0a26a6aac4615d83.tar.gz
gentoo-4365ff2aace8b178624ca84a0a26a6aac4615d83.tar.bz2
gentoo-4365ff2aace8b178624ca84a0a26a6aac4615d83.zip
dev-python/simplejson: Bump to 3.17.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simplejson')
-rw-r--r--dev-python/simplejson/Manifest1
-rw-r--r--dev-python/simplejson/simplejson-3.17.5.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/simplejson/Manifest b/dev-python/simplejson/Manifest
index 3095b65df824..183b775a0ae3 100644
--- a/dev-python/simplejson/Manifest
+++ b/dev-python/simplejson/Manifest
@@ -1 +1,2 @@
DIST simplejson-3.17.3.tar.gz 82434 BLAKE2B ae6f303a204f0c5a6bc7a10aa8da3dadbd4fc3a257abb15e330d13299dcbd5bc6be97506f6d5b48f3a3fe24570ac28b331644870d03aa30f80d40e69f4d2ec15 SHA512 b4ccdff3df2c87ed6f5119e93560ea7ddf60fcc64f996efeef1f6077f3a559c8f9ea77fd217348c1cba2de50e40523714899de110614953baf8385bb78d10af6
+DIST simplejson-3.17.5.tar.gz 83182 BLAKE2B 8fbaa83c81a7478b3c62c6625e717874f6dd3bef236b85504788a66d2b820dbf601e65edbcc7056528e67a66b806b3847b8efcc522464604bd4987dce9870643 SHA512 f5af32e4f9b4575323f9c0eb8163e794270a8607710d08a72cece953f57861e3619038798369ea049d82b9b53f293b9d9eefdeb4dd94ab4f043506bc3f1ddfad
diff --git a/dev-python/simplejson/simplejson-3.17.5.ebuild b/dev-python/simplejson/simplejson-3.17.5.ebuild
new file mode 100644
index 000000000000..4eeb70ccbda3
--- /dev/null
+++ b/dev-python/simplejson/simplejson-3.17.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.org/project/simplejson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+DOCS=( README.rst CHANGES.txt )
+
+distutils_enable_tests unittest