summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-12 15:36:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-12 16:33:11 +0100
commitc561a076c7487f09525e909c39a6f440d8eb416b (patch)
tree643a2a04c4d4b4f23c4237e8ffd18097d59514aa /dev-python/shapely
parentapp-emacs/cider: add official CIDER website links (diff)
downloadgentoo-c561a076c7487f09525e909c39a6f440d8eb416b.tar.gz
gentoo-c561a076c7487f09525e909c39a6f440d8eb416b.tar.bz2
gentoo-c561a076c7487f09525e909c39a6f440d8eb416b.zip
dev-python/shapely: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/shapely')
-rw-r--r--dev-python/shapely/Manifest1
-rw-r--r--dev-python/shapely/metadata.xml2
-rw-r--r--dev-python/shapely/shapely-2.0.0.ebuild46
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/shapely/Manifest b/dev-python/shapely/Manifest
index 0c2de6069e9d..253be6e83ea1 100644
--- a/dev-python/shapely/Manifest
+++ b/dev-python/shapely/Manifest
@@ -1 +1,2 @@
DIST shapely-1.8.5.post1.gh.tar.gz 323178 BLAKE2B 05ff22f972446da340714548f5a2ad233f8bac8bb0710a8c5444dc44e7d5ad0d2c2d37bc3ddb987f57accd065c75c9627752a6c6cb3590621e39812674c678e9 SHA512 99a406833ebd13cb3f88fb710ed66f545a0b128d201e82ff381de0214cde38c685a622f78e964d6d41fc9ba096bc62e63bf9da04d216dedf2f96bb1e3496d48f
+DIST shapely-2.0.0.gh.tar.gz 324420 BLAKE2B efe8aea8d9507bf2d2c31ca7dfaa6a531f71530243dd8c23046f4803d36e36b1636a07255c634fc5d6e30391aac260dcdaeb1f4c2aa73297a90f71134c1bbc15 SHA512 15e261901ada47ef2a9d2f213a2634152bc43799fd27421726b5e6525f91aef60c0bbc5f38e5185bf89ec795b5fa703688d2b08d4d3d14c9274515c5935157cb
diff --git a/dev-python/shapely/metadata.xml b/dev-python/shapely/metadata.xml
index 6432c651184e..b2f2b59a497d 100644
--- a/dev-python/shapely/metadata.xml
+++ b/dev-python/shapely/metadata.xml
@@ -18,6 +18,6 @@
<bugs-to>https://github.com/shapely/shapely/issues</bugs-to>
<doc>https://shapely.readthedocs.io</doc>
<remote-id type="github">shapely/shapely</remote-id>
- <remote-id type="pypi">Shapely</remote-id>
+ <remote-id type="pypi">shapely</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/shapely/shapely-2.0.0.ebuild b/dev-python/shapely/shapely-2.0.0.ebuild
new file mode 100644
index 000000000000..bdf682ce1ecb
--- /dev/null
+++ b/dev-python/shapely/shapely-2.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+DESCRIPTION="Geometric objects, predicates, and operations"
+HOMEPAGE="
+ https://pypi.org/project/shapely/
+ https://github.com/shapely/shapely/
+"
+SRC_URI="
+ https://github.com/shapely/shapely/archive/${PV/_p/.post}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=sci-libs/geos-3.9
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/numpy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/matplotlib
+
+python_compile_all() {
+ rm -r shapely || die
+ distutils-r1_python_compile_all
+}