summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-05-08 22:12:13 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2023-05-08 22:31:00 +0300
commit893c7afc22737879da06a0c60fc08023472948a7 (patch)
tree42b9e8eefa533551d2abc07f9087086cc45d6e84 /dev-python/selenium
parentdev-python/sentry-sdk: add 1.22.2 (diff)
downloadgentoo-893c7afc22737879da06a0c60fc08023472948a7.tar.gz
gentoo-893c7afc22737879da06a0c60fc08023472948a7.tar.bz2
gentoo-893c7afc22737879da06a0c60fc08023472948a7.zip
dev-python/selenium: add 4.9.1
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/selenium')
-rw-r--r--dev-python/selenium/Manifest2
-rw-r--r--dev-python/selenium/selenium-4.9.1.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index 61cfa66f7284..611805eb873d 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,2 +1,4 @@
DIST selenium-4.9.0.tar.gz 6336895 BLAKE2B 4a812324abd1903f14b03a73d21125eb83b753a553bcc4515aa4a3dc792bfb07bfacf34e35357f81c36675d9079bafe5f289a63c709df57358103a9141cef535 SHA512 3bfba3d862de73261e984e4dce3c2ff77b0f57074073b38648cbbe6908f2d20a5fadef8b23b6a292d780bfe3556291e26c2a7b1cc4b314cc959e78e0a2dcc6dc
+DIST selenium-4.9.1.tar.gz 6341857 BLAKE2B dd6461e096a15170c37b3e95f2f492da5bc16d1b2bcdc3e0528f5f27219529a850a5f01363f91d829ca05700fde800d55c5e43d758d566e48faba494610a25d4 SHA512 e9ff93c0dfb8f561bbfd2b31e555c7e815bba677b8391296e696ced7ce63daa12e169bd2ce5e02c0fb1499a028a7d674f6202e512082993b5a59bddab5011a3c
DIST selenium-selenium-4.9.0.gh.tar.gz 90247221 BLAKE2B fe99ac519ef4ced5f61721d1e3bae70e938b4a481582623a33f4d5a2fd1978c42e216501eb25ac7496957c2ea37a3ad97aff7ab7adf440e1428a311410024aca SHA512 9e745eae4cf6ea95fe1268b79a80734f4b67b0948fa5bfb144d6b681cd4b353add5c1a1d16b3f35652b6fa4a5b135f8a5203de97fcb9af0c27060a45b6269225
+DIST selenium-selenium-4.9.1.gh.tar.gz 90261099 BLAKE2B 4ef22ed67881036b3b20642bf6288a9afd518364f0271843b9d4ebcc2ccdfe3f259d5f6e7e52c375ff94e65f533810d3b51059433890277f440d23e50c5b1acf SHA512 fac1b0c50b6983fce7d2e5b40347dde05ca8b2907a9a6e06905f521d3bc9a05f61eed3bc07b91b0163958580a67605500d3e928aeed73b44b34a4b2a7ebeaca3
diff --git a/dev-python/selenium/selenium-4.9.1.ebuild b/dev-python/selenium/selenium-4.9.1.ebuild
new file mode 100644
index 000000000000..b61d9b6e44dc
--- /dev/null
+++ b/dev-python/selenium/selenium-4.9.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
+TEST_TAG=${P}
+TEST_P=selenium-${TEST_TAG}
+
+DESCRIPTION="Python language binding for Selenium Remote Control"
+HOMEPAGE="
+ https://www.seleniumhq.org/
+ https://github.com/SeleniumHQ/selenium/tree/trunk/py/
+ https://pypi.org/project/selenium/
+"
+SRC_URI+="
+ test? (
+ https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
+ -> ${TEST_P}.gh.tar.gz
+ )
+"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
+ <dev-python/trio-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.17[${PYTHON_USEDEP}]
+ <dev-python/trio-websocket-1[${PYTHON_USEDEP}]
+ >=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: we may need extra setup or deps
+ test/selenium
+
+ # expects vanilla certifi
+ test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
+ )
+
+ cd "${WORKDIR}/${TEST_P}/py" || die
+ rm -rf selenium || die
+ # https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
+ # seriously?
+ epytest -o "python_files=*_tests.py test_*.py"
+}