summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/rope
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest2
-rw-r--r--dev-python/rope/files/rope-0.9.3-fix_tests_results.patch16
-rw-r--r--dev-python/rope/files/rope-0.9.3-python2.7.patch76
-rw-r--r--dev-python/rope/metadata.xml11
-rw-r--r--dev-python/rope/rope-0.10.2.ebuild28
-rw-r--r--dev-python/rope/rope-0.9.4-r1.ebuild31
6 files changed, 164 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
new file mode 100644
index 000000000000..cedad02a835f
--- /dev/null
+++ b/dev-python/rope/Manifest
@@ -0,0 +1,2 @@
+DIST rope-0.10.2.tar.gz 221523 SHA256 fffca108c0d6a711121ce11fed286f4ddc5791c7a6c3f079221a9303d1ddb465 SHA512 9d3c3f2197b8eff87301d90dbf58872070e8c352704f50c942c270a05ba08504aeb2bb8f6d00902954abaa4d721d2a246c720f94547d8d3517cb84c0b31d9bc2 WHIRLPOOL 196587c655e6bffb26bc6498e57a833ddfc5c3ec0ccaa0b0baff9618f0e9fc5d18612fdada1a91e3ca8813b2c3c254691d462f2ff622af371a78b22b2024016f
+DIST rope-0.9.4.tar.gz 221516 SHA256 2dc0342604851d8fbdafa198172eab5da7ed422759016669056181e21c54a6ba SHA512 462ce4fec7decdca67400e01fc08cb924019e71011fa0c50c529ff0ba377b277685f34a78796b5c30c20ac063aaba1b0b61bd9ac5b05625399e9d71ac625e534 WHIRLPOOL 7fcdfcd0d82e869b8008cedb7fc0ecbb8f7da302994129273e342346becde8cbd5915f9e04d2a9de57eb2b42b4487329109c159277f8255e386fc2765213a94b
diff --git a/dev-python/rope/files/rope-0.9.3-fix_tests_results.patch b/dev-python/rope/files/rope-0.9.3-fix_tests_results.patch
new file mode 100644
index 000000000000..5250cc66f948
--- /dev/null
+++ b/dev-python/rope/files/rope-0.9.3-fix_tests_results.patch
@@ -0,0 +1,16 @@
+https://bitbucket.org/agr/rope/issue/7/
+
+--- ropetest/__init__.py
++++ ropetest/__init__.py
+@@ -1,3 +1,4 @@
++import sys
+ import unittest
+
+ import ropetest.projecttest
+@@ -31,4 +32,5 @@
+
+ if __name__ == '__main__':
+ runner = unittest.TextTestRunner()
+- runner.run(suite())
++ result = runner.run(suite())
++ sys.exit(not result.wasSuccessful())
diff --git a/dev-python/rope/files/rope-0.9.3-python2.7.patch b/dev-python/rope/files/rope-0.9.3-python2.7.patch
new file mode 100644
index 000000000000..f1a4fe4d2d32
--- /dev/null
+++ b/dev-python/rope/files/rope-0.9.3-python2.7.patch
@@ -0,0 +1,76 @@
+Apply upstream changesets:
+https://bitbucket.org/agr/rope/changeset/1c100ebabc16
+https://bitbucket.org/agr/rope/changeset/f5eb880e0be2
+
+to fix issues with python 2.7
+
+https://bugs.gentoo.org/show_bug.cgi?id=326401
+https://bitbucket.org/agr/rope/issue/8/
+
+--- a/rope/base/ast.py
++++ b/rope/base/ast.py
+@@ -27,6 +27,10 @@
+ method_name = '_' + node.__class__.__name__
+ method = getattr(walker, method_name, None)
+ if method is not None:
++ if isinstance(node, _ast.ImportFrom) and node.module is None:
++ # In python < 2.7 ``node.module == ''`` for relative imports
++ # but for python 2.7 it is None. Generalizing it to ''.
++ node.module = ''
+ return method(node)
+ for child in get_child_nodes(node):
+ walk(child, walker)
+--- a/rope/base/oi/runmod.py
++++ b/rope/base/oi/runmod.py
+@@ -187,6 +187,7 @@
+
+ def close(self):
+ self.sender.close()
++ sys.settrace(None)
+
+ def _realpath(path):
+ return os.path.realpath(os.path.abspath(os.path.expanduser(path)))
+--- a/rope/refactor/importutils/module_imports.py
++++ b/rope/refactor/importutils/module_imports.py
+@@ -428,7 +428,8 @@
+ if node.level:
+ level = node.level
+ import_info = importinfo.FromImport(
+- node.module, level, self._get_names(node.names))
++ node.module or '', # see comment at rope.base.ast.walk
++ level, self._get_names(node.names))
+ start_line = node.lineno
+ self.imports.append(importinfo.ImportStatement(
+ import_info, node.lineno, end_line,
+--- a/rope/refactor/patchedast.py
++++ b/rope/refactor/patchedast.py
+@@ -350,7 +350,8 @@
+ children = ['from']
+ if node.level:
+ children.append('.' * node.level)
+- children.extend([node.module, 'import'])
++ children.extend([node.module or '', # see comment at rope.base.ast.walk
++ 'import'])
+ children.extend(self._child_nodes(node.names, ','))
+ self._handle(node, children)
+
+--- a/ropetest/refactor/patchedasttest.py
++++ b/ropetest/refactor/patchedasttest.py
+@@ -441,6 +441,17 @@
+ 'import', ' ', 'alias'])
+ checker.check_children('alias', ['y', ' ', 'as', ' ', 'z'])
+
++ @testutils.run_only_for_25
++ def test_from_node_relative_import(self):
++ source = 'from . import y as z\n'
++ ast = patchedast.get_patched_ast(source, True)
++ checker = _ResultChecker(self, ast)
++ checker.check_region('ImportFrom', 0, len(source) - 1)
++ checker.check_children(
++ 'ImportFrom', ['from', ' ', '.', '', '', ' ',
++ 'import', ' ', 'alias'])
++ checker.check_children('alias', ['y', ' ', 'as', ' ', 'z'])
++
+ def test_simple_gen_expr_node(self):
+ source = 'zip(i for i in x)\n'
+ ast = patchedast.get_patched_ast(source, True)
diff --git a/dev-python/rope/metadata.xml b/dev-python/rope/metadata.xml
new file mode 100644
index 000000000000..99ac729c5a3f
--- /dev/null
+++ b/dev-python/rope/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription lang='en'>
+ Rope is a python refactoring library.
+</longdescription>
+<upstream>
+ <remote-id type="pypi">rope</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/dev-python/rope/rope-0.10.2.ebuild b/dev-python/rope/rope-0.10.2.ebuild
new file mode 100644
index 000000000000..6c37962b4da4
--- /dev/null
+++ b/dev-python/rope/rope-0.10.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="http://rope.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
+}
+
+src_install() {
+ distutils-r1_src_install
+ docinto docs
+ dodoc docs/*.rst
+}
diff --git a/dev-python/rope/rope-0.9.4-r1.ebuild b/dev-python/rope/rope-0.9.4-r1.ebuild
new file mode 100644
index 000000000000..de458c657ced
--- /dev/null
+++ b/dev-python/rope/rope-0.9.4-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="http://rope.sourceforge.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib:." ${EPYTHON} ropetest/__init__.py
+}
+
+src_install() {
+ distutils-r1_src_install
+ docinto docs
+ dodoc docs/*.txt
+}