summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-30 04:50:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-30 04:50:45 +0200
commit2f60a7517e0d7735f9968f786ab761c0640504ac (patch)
tree2cd58822bba0b398e59661f7b14d00fda61c63d0 /dev-python/rope
parentdev-python/openstacksdk: Bump to 1.3.1 (diff)
downloadgentoo-2f60a7517e0d7735f9968f786ab761c0640504ac.tar.gz
gentoo-2f60a7517e0d7735f9968f786ab761c0640504ac.tar.bz2
gentoo-2f60a7517e0d7735f9968f786ab761c0640504ac.zip
dev-python/rope: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rope')
-rw-r--r--dev-python/rope/Manifest1
-rw-r--r--dev-python/rope/rope-1.9.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/rope/Manifest b/dev-python/rope/Manifest
index 9ad7e44a2945..369ee811fd12 100644
--- a/dev-python/rope/Manifest
+++ b/dev-python/rope/Manifest
@@ -1 +1,2 @@
DIST rope-1.8.0.tar.gz 297235 BLAKE2B e9849b75b3ec640201b30318863066b969b5ebde98522c3c09f70bcc344bce5f604601bd155ed0ce6fb3eebb392ea3669f77fb2da21c11078e1041ae13464fd8 SHA512 2fa8e56d6d7fd0a15acb16a1fe27db89d9c2dd6f93fabd448509a112a6ef7f3dfdd4d3d544cf1218149c7a7fa1db9908b107b6eae6e89299f32c0d1586ceaf4e
+DIST rope-1.9.0.tar.gz 298227 BLAKE2B c136678bdd9d580d0f0ada93e5c61b963bfe5b9867b39f8c9ba35578f4c8b2ebca1031d00bea4bf2f10ebdf300bc4920827a3325a5c26498efb3e6a4af5b016a SHA512 fd8cc75c70814afc427fbccbe8a1389773737ee664a42a43bb2fb7e7ff667fac4680d233c751ee15b03e41b60ba270b3cf48b1a766420468e4a7c974e4c0158c
diff --git a/dev-python/rope/rope-1.9.0.ebuild b/dev-python/rope/rope-1.9.0.ebuild
new file mode 100644
index 000000000000..d3ca80b1d3ec
--- /dev/null
+++ b/dev-python/rope/rope-1.9.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/pytoolconfig-1.2.2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/build[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # our venv style confuses this comparison
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_source_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_typing
+ ropetest/contrib/autoimport/utilstest.py::test_get_package_tuple_compiled
+)