summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-10-15 20:42:39 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-10-15 21:04:11 -0500
commit04b3e5fb9ca9de2405b8e88fe0a093660b99132f (patch)
tree1f8df772a943c3d4fe7e23e369921b5881563a06 /dev-python/restructuredtext-lint
parentdev-python/bashate: set DISTUTILS_USE_SETUPTOOLS=rdepend (diff)
downloadgentoo-04b3e5fb9ca9de2405b8e88fe0a093660b99132f.tar.gz
gentoo-04b3e5fb9ca9de2405b8e88fe0a093660b99132f.tar.bz2
gentoo-04b3e5fb9ca9de2405b8e88fe0a093660b99132f.zip
dev-python/restructuredtext-lint: set DISTUTILS_USE_SETUPTOOLS=rdepend
Closes: https://bugs.gentoo.org/748381 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/restructuredtext-lint')
-rw-r--r--dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild b/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
index 6e6ed25ed5f2..5ed34281d515 100644
--- a/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
+++ b/dev-python/restructuredtext-lint/restructuredtext-lint-1.3.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -20,7 +21,6 @@ IUSE="test"
RESTRICT="!test? ( test )"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]