summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-11-11 20:23:37 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-11-11 20:23:37 +0700
commit3b48b6d3364d12f88620ea019447ab9705d42105 (patch)
tree96c08994554c1c40bd07409035efb5c8ed4deb53 /dev-python/qtawesome/qtawesome-0.5.2.ebuild
parentdev-python/rpyc: bump to 4.0.2 (diff)
downloadgentoo-3b48b6d3364d12f88620ea019447ab9705d42105.tar.gz
gentoo-3b48b6d3364d12f88620ea019447ab9705d42105.tar.bz2
gentoo-3b48b6d3364d12f88620ea019447ab9705d42105.zip
dev-python/qtawesome: bump to 0.5.2
Signed-off-by: Andrey Grozin <grozin@gentoo.org> Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'dev-python/qtawesome/qtawesome-0.5.2.ebuild')
-rw-r--r--dev-python/qtawesome/qtawesome-0.5.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/qtawesome/qtawesome-0.5.2.ebuild b/dev-python/qtawesome/qtawesome-0.5.2.ebuild
new file mode 100644
index 000000000000..1e2cc4cff8aa
--- /dev/null
+++ b/dev-python/qtawesome/qtawesome-0.5.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+inherit eutils distutils-r1
+
+DESCRIPTION="Enables iconic fonts such as Font Awesome in PyQt"
+HOMEPAGE="https://github.com/spyder-ide/qtawesome/ https://pypi.org/project/QtAwesome/"
+MY_PN="QtAwesome"
+MY_P="${MY_PN}-${PV}"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-fonts/fontawesome"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_P}"