summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-13 08:13:05 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-13 10:05:13 +0200
commit263ee8f895c2fe51bd3b44fc69473c8b61fa9159 (patch)
treef36c27975db625111d519c051deb9f7b7f7a5de9 /dev-python/pytz
parentdev-python/tomlkit: Bump to 0.11.4 (diff)
downloadgentoo-263ee8f895c2fe51bd3b44fc69473c8b61fa9159.tar.gz
gentoo-263ee8f895c2fe51bd3b44fc69473c8b61fa9159.tar.bz2
gentoo-263ee8f895c2fe51bd3b44fc69473c8b61fa9159.zip
dev-python/pytz: Bump to 2022.2.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytz')
-rw-r--r--dev-python/pytz/Manifest1
-rw-r--r--dev-python/pytz/pytz-2022.2.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index 21b9d82fa36e..dcf992af2219 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -1,2 +1,3 @@
DIST pytz-2022.1.tar.gz 320473 BLAKE2B 9a745629a9e4547f8c8765353e58baa6d63e3e6b357e9ca88f69928fb9350cebb6bb3371eee419b4b92b29e6253f8c24af8c781f10d72211d78cb699043496fe SHA512 7737aa28626743026b7de932b27bf44d7b209f495d9dd7f90c6448ec271e007f23004fcd04982e2ca6d0a4075206e1dae7b8836319c299b5559c514366d518a6
+DIST pytz-2022.2.1.tar.gz 316105 BLAKE2B 74a3f416c5e15a050cc62594851d80022c81cb611e6c1d1130cfc7e1bc9cb3b833edca9e67203695c50abb7587bf514216f8c0153890658bc8a9f1498e82f867 SHA512 9c78d9f484e2e0e101ca7e10fba8e6c9870255b2c320b3499a0cc9b480adac64b07f2f124048aa957c6bc9311a4ac43060368e1f0d85d8e8c8f7df598e47912b
DIST pytz-2022.2.tar.gz 322487 BLAKE2B 37aa920a571b751e7fe55140561f9d895273c63c5ec4f0ce32e12a9966c903de590d1bbeb8c3d29eeb6ffa46ecf68584128aefc4349c3fde2af923f275c1c01c SHA512 7a908801585f95dc7e19756b454b38ca991e3c280ab4d946152ff0ecfb5ac89e266b21c5a165797ec64c9aaaaadf729f935d7eebd3f918df3143bd68b23876cf
diff --git a/dev-python/pytz/pytz-2022.2.1.ebuild b/dev-python/pytz/pytz-2022.2.1.ebuild
new file mode 100644
index 000000000000..02775780a89a
--- /dev/null
+++ b/dev-python/pytz/pytz-2022.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="
+ https://pythonhosted.org/pytz/
+ https://pypi.org/project/pytz/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+DEPEND="
+ || (
+ >=sys-libs/timezone-data-2017a
+ sys-libs/glibc[vanilla]
+ )
+"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${EPYTHON}" pytz/tests/test_tzinfo.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}