summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2016-07-16 14:04:51 +0900
committerAaron Bauman <bman@gentoo.org>2016-07-16 14:04:51 +0900
commit5114a523720d258687cdeec77c0b7875033bd8a1 (patch)
treec53a72b8dd837d30b2ac73679662ad4bb82770ef /dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
parentdev-lang/rebol-bin: bump to snapshot from 2014, bug #450864 (diff)
downloadgentoo-5114a523720d258687cdeec77c0b7875033bd8a1.tar.gz
gentoo-5114a523720d258687cdeec77c0b7875033bd8a1.tar.bz2
gentoo-5114a523720d258687cdeec77c0b7875033bd8a1.zip
dev-python/python-zipstream: new package required by >=net-misc/gns3-server-1.5.1
Diffstat (limited to 'dev-python/python-zipstream/python-zipstream-1.1.4.ebuild')
-rw-r--r--dev-python/python-zipstream/python-zipstream-1.1.4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild b/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
new file mode 100644
index 000000000000..f14c80904853
--- /dev/null
+++ b/dev-python/python-zipstream/python-zipstream-1.1.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="A zip archive generator"
+HOMEPAGE="https://github.com/allanlei/python-zipstream"
+SRC_URI="https://github.com/allanlei/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+python_test() {
+ nosetests || die "tests failed under ${EPYTHON}"
+}