summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-26 22:16:53 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-26 22:16:53 +0100
commit02a1a3024f8468c99284717927343a6adf690cfa (patch)
tree51f4522fc8e6b71813d1d3ff576ae0d71fa5f2a6 /dev-python/python-utils
parentdev-python/coverage: Bump to 5.4 (diff)
downloadgentoo-02a1a3024f8468c99284717927343a6adf690cfa.tar.gz
gentoo-02a1a3024f8468c99284717927343a6adf690cfa.tar.bz2
gentoo-02a1a3024f8468c99284717927343a6adf690cfa.zip
dev-python/python-utils: Bump to 2.5.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-2.5.5.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index e09474476c13..ec8a078019e0 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -3,3 +3,4 @@ DIST python-utils-2.4.0.tar.gz 22230 BLAKE2B 1c144f62a009a2470ec43341283048842cb
DIST python-utils-2.5.1.tar.gz 115307 BLAKE2B 2938b9f188c92d407baf09147338ea2c54b9c70c5a8746f14cd4d4b5026e6bd7bab418c9cde6c99ae4c4072da6967033bf59ed32acb0e21bfb5aacff8640620e SHA512 886ed6c1c7027012c1e5a59dfe3f81ac2b07974cc5869b5cb8f5fc91f8ca733acf0ee03dbb559be69a389228974d713666ced950ec766117075aa5ea781216fb
DIST python-utils-2.5.2.tar.gz 14034 BLAKE2B 1d9ec9ba84ee1ebff2c4ef915bb0e57c34185c0577252f8b4cc9678f2e5b6e5a815f7c049c2f512d2f79aa8be855870ff21ec2291b1305bf8a369614220bc582 SHA512 5bcf4f33eac88b83e0cccf6b50162a5c913d9e72c4395b2265017cda566c91fa36c24eb5c3d23269b71330df65ac14226834d7b339b5b767afad3177734b9934
DIST python-utils-2.5.3.tar.gz 49110 BLAKE2B 13b6a20278c73acc1e52c12dff3833b1dc6ebe6c1373ab5b972300d778bb4f110af79333dddc805b29a7d34265973ebf0136a607b82880b5c43c4c4d0c9f391c SHA512 7e0a584a80ce5eca654eca5335080b98b21bed11bcef7d238639d07e386f58d44a00765133b487dc5492cb35a221bc9e8042513099ee3b49177c77334129c8bd
+DIST python-utils-2.5.5.tar.gz 14069 BLAKE2B 44874a8d8089f18ff79eccf94f0b436c234dfc7d691e5b9e8e1d41e4cd3cc1005bfca44822f0b3558496ff80dc12443dcd2f29ece6c65956e17ace09c1c5663e SHA512 448ff86a7f05b764f260398496fc722c2bde335aec6402c686e8fc063faa8999088f5a6b7a960b415fb9a3b4d35bc9f26aa74fe4dfe02c61926c6cfd31a3876c
diff --git a/dev-python/python-utils/python-utils-2.5.5.ebuild b/dev-python/python-utils/python-utils-2.5.5.ebuild
new file mode 100644
index 000000000000..b83efbe8075e
--- /dev/null
+++ b/dev-python/python-utils/python-utils-2.5.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} pypy3)
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="https://pypi.org/project/python-utils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--flake8/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}