summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-iwscan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-iwscan')
-rw-r--r--dev-python/python-iwscan/Manifest1
-rw-r--r--dev-python/python-iwscan/files/python-iwscan-20080402-wireless-tools-30.patch14
-rw-r--r--dev-python/python-iwscan/metadata.xml9
-rw-r--r--dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild29
4 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/python-iwscan/Manifest b/dev-python/python-iwscan/Manifest
new file mode 100644
index 000000000000..6bc6263a7125
--- /dev/null
+++ b/dev-python/python-iwscan/Manifest
@@ -0,0 +1 @@
+DIST python-iwscan-20080402.tar.bz2 16891 SHA256 1e534508597bd86cfab3f3d7b5e1f6d924812f374e3e26c1546c4ecbb07f8b8c SHA512 9e9d5e1b2cc491879a4f8a216044f46253820c6c8f30904a1867f758f6d158a9270c9c70a91f22a80f15fbe0446d786869104c5dc5d6bfcab470a79478f533d2 WHIRLPOOL de4a05b688e160ef721de71304a44731e5d28e803c27619d40a5c467674dcc2c5413c80ed5b97e1a739f6e3a41ec69b26ae3b2d71f17b3d5d088906d1481077d
diff --git a/dev-python/python-iwscan/files/python-iwscan-20080402-wireless-tools-30.patch b/dev-python/python-iwscan/files/python-iwscan-20080402-wireless-tools-30.patch
new file mode 100644
index 000000000000..16a9dce1858f
--- /dev/null
+++ b/dev-python/python-iwscan/files/python-iwscan-20080402-wireless-tools-30.patch
@@ -0,0 +1,14 @@
+--- pyiwscan.c
++++ pyiwscan.c
+@@ -13,6 +13,11 @@
+ #include <structmember.h>
+ #include <iwlib.h>
+
++/* PROC_NET_WIRELESS is defined in iwlib-private.h since wireless-tools-30_pre9 */
++#ifndef PROC_NET_WIRELESS
++#define PROC_NET_WIRELESS "/proc/net/wireless"
++#endif
++
+ #define IWSCAN_VERSION_MAJOR 0
+ #define IWSCAN_VERSION_MINOR 7
+ #define IWSCAN_VERSION_MICRO 0
diff --git a/dev-python/python-iwscan/metadata.xml b/dev-python/python-iwscan/metadata.xml
new file mode 100644
index 000000000000..b193248853bc
--- /dev/null
+++ b/dev-python/python-iwscan/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<maintainer>
+ <email>tomka@gentoo.org</email>
+ <name>Thomas Kahle</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild b/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild
new file mode 100644
index 000000000000..c111ce46fdcd
--- /dev/null
+++ b/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="A Python extension for iwscan access"
+HOMEPAGE="http://projects.otaku42.de/browser/python-iwscan"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="net-wireless/wireless-tools"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-wireless-tools-30.patch"
+)
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}