summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorktrace <coyote@bks.tv>2018-01-23 23:41:02 +0300
committerMichał Górny <mgorny@gentoo.org>2018-03-22 17:17:32 +0100
commit3e75cda13c5d28d7197e9850c38ec4e013103475 (patch)
tree490dfd3016dddacb9d79e1442f01c2a318dd50b3 /dev-python/python-gammu
parentapp-mobilephone/gammu: remove old 1.38.4 (diff)
downloadgentoo-3e75cda13c5d28d7197e9850c38ec4e013103475.tar.gz
gentoo-3e75cda13c5d28d7197e9850c38ec4e013103475.tar.bz2
gentoo-3e75cda13c5d28d7197e9850c38ec4e013103475.zip
dev-python/python-gammu: bump version to 2.11
Closes: https://bugs.gentoo.org/644862 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/python-gammu')
-rw-r--r--dev-python/python-gammu/Manifest1
-rw-r--r--dev-python/python-gammu/python-gammu-2.11.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-gammu/Manifest b/dev-python/python-gammu/Manifest
index b3cd94a458f0..6c4bf1372ab8 100644
--- a/dev-python/python-gammu/Manifest
+++ b/dev-python/python-gammu/Manifest
@@ -1 +1,2 @@
+DIST python-gammu-2.11.tar.gz 135567 BLAKE2B 133172cfd0715ff6b5bd47b93e5d93d52af3e608459ba1158bf008da9b5f24f6d155c04334dea7ff2cacdea678f00d986838a139290d5f8ac874bb9702fcd5e6 SHA512 cdf3a54fc538fecdbe3dae63f0534094ce94a289998f9b670a0b3e12a3c571eb46ee86eae67a7a8d2428698850046d5c75569753bf77551cd395d315e6f9b70d
DIST python-gammu-2.5.tar.gz 133090 BLAKE2B aced85e9f7a4d861a8f11ff0ebb97a7f3062e5f3ad3a60614f6f5f16a30b5f5cfbe70958e630dd55d02d0f190648f2976cf60ef3259c21fbc882acc865a4ce8d SHA512 e61bb340546cf3f98c20ff5d4ef25ca05676b4dea91e02aeee2856f091ac12fbf07a597637f9562432e298bf9678ff4445d24d8cdf96274b735aa9754b364e58
diff --git a/dev-python/python-gammu/python-gammu-2.11.ebuild b/dev-python/python-gammu/python-gammu-2.11.ebuild
new file mode 100644
index 000000000000..7c6896eb4176
--- /dev/null
+++ b/dev-python/python-gammu/python-gammu-2.11.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for Gammu"
+HOMEPAGE="https://wammu.eu/python-gammu/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=">=app-mobilephone/gammu-1.34.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ $(python_gen_impl_dep sqlite)
+ app-mobilephone/gammu[dbi]
+ )"
+
+DOCS=( AUTHORS NEWS.rst README.rst )
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}