summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2015-09-08 02:39:59 +0200
committerJulian Ospald <hasufell@gentoo.org>2015-09-08 19:40:14 +0200
commit3417e3bd1c4e536f7dff658009d2b004a8c4f6f0 (patch)
treebdfe1d71c30948943f54ad28f640894beb7f1a4d /dev-python/python-eventlib
parentdev-python/python-xcaplib: initial import of version 1.1.0 (diff)
downloadgentoo-3417e3bd1c4e536f7dff658009d2b004a8c4f6f0.tar.gz
gentoo-3417e3bd1c4e536f7dff658009d2b004a8c4f6f0.tar.bz2
gentoo-3417e3bd1c4e536f7dff658009d2b004a8c4f6f0.zip
dev-python/python-eventlib: initial import of version 0.2.1
Gentoo-Bug: 446192
Diffstat (limited to 'dev-python/python-eventlib')
-rw-r--r--dev-python/python-eventlib/Manifest1
-rw-r--r--dev-python/python-eventlib/metadata.xml16
-rw-r--r--dev-python/python-eventlib/python-eventlib-0.2.1.ebuild25
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/python-eventlib/Manifest b/dev-python/python-eventlib/Manifest
new file mode 100644
index 000000000000..6ce51e624262
--- /dev/null
+++ b/dev-python/python-eventlib/Manifest
@@ -0,0 +1 @@
+DIST python-eventlib-0.2.1.tar.gz 189314 SHA256 25224794420f430946fe46932718b521a6264903fe8c0ed3563dfdb844c623e7 SHA512 f1ca3c6eb54677068ec209386f09c695c141b08e148475ee3cc69e667dd96af3637a66660e9105a195620f3bde10d4b18087612c501764d52413982c2721e1a6 WHIRLPOOL a95ac7283d1425161d190c17ceb7d58ff81a3ec9aa09066226c177a4d7343c2f99ea19c7866d4a03d281241337efa877020c85956c7c81cfb0444e457fda9f9f
diff --git a/dev-python/python-eventlib/metadata.xml b/dev-python/python-eventlib/metadata.xml
new file mode 100644
index 000000000000..a841434212dc
--- /dev/null
+++ b/dev-python/python-eventlib/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ </maintainer>
+ <longdescription lang="en">
+ Eventlib is a networking library written in Python. It achieves
+ high scalability by using non-blocking io while at the same time
+ retaining high programmer usability by using coroutines to make
+ the non-blocking io operations appear blocking at the source code
+ level.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-eventlib/python-eventlib-0.2.1.ebuild b/dev-python/python-eventlib/python-eventlib-0.2.1.ebuild
new file mode 100644
index 000000000000..3dab2cae473c
--- /dev/null
+++ b/dev-python/python-eventlib/python-eventlib-0.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_REQ_USE="ssl"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Coroutine-based networking library"
+HOMEPAGE="http://sipsimpleclient.org"
+SRC_URI="http://download.ag-projects.com/SipClient/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+"