summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-evdev
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-evdev')
-rw-r--r--dev-python/python-evdev/Manifest2
-rw-r--r--dev-python/python-evdev/metadata.xml10
-rw-r--r--dev-python/python-evdev/python-evdev-0.4.3.ebuild19
-rw-r--r--dev-python/python-evdev/python-evdev-0.4.5.ebuild19
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/python-evdev/Manifest b/dev-python/python-evdev/Manifest
new file mode 100644
index 000000000000..b5c73cea008f
--- /dev/null
+++ b/dev-python/python-evdev/Manifest
@@ -0,0 +1,2 @@
+DIST python-evdev-0.4.3.tar.gz 27658 SHA256 011db63c94e668997ce0609e4a3cb04b92aca21304657151e6567e938de5efc6 SHA512 7bbc4339bde599f38423f88b3e5a4a4408b9214c9b622915b6f31dad50e08879d914fc83e8d95f66c158d5dd2d29e72907c4e3b0a97a3dbdfb7bde9013e161ec WHIRLPOOL 120aea7069cbe86463975103b87e7eca529df34ce14f69fe2378802f867b434a89aadfcdcab1c991ed25114bfe574452e12b33adbacadd1655e2013dc20f4dcb
+DIST python-evdev-0.4.5.tar.gz 30415 SHA256 70852905a4d0ad541ee0b8c58c566160df5bd08c69c778cbb9ebacfc50a6be61 SHA512 9d2c09c6dddd96bf6c5c639babe8a2c7dc81023de46ffcfe8e4d76126072fb380d3e726a3db1ae8025d4c816218f981ff23df86e20e0dc90c4ee4ca97ac57db5 WHIRLPOOL b548ad9cee8277bf192c30332ca0b0eeee98f90fe77db86ecdf0106948e5c2aba86ae9c950611357c3e41b9ec9e16a96525546d762c4ecf1d05f660d7107eb57
diff --git a/dev-python/python-evdev/metadata.xml b/dev-python/python-evdev/metadata.xml
new file mode 100644
index 000000000000..fd2e57a093f3
--- /dev/null
+++ b/dev-python/python-evdev/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">gvalkov/python-evdev</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-evdev/python-evdev-0.4.3.ebuild b/dev-python/python-evdev/python-evdev-0.4.3.ebuild
new file mode 100644
index 000000000000..8219a89a9fda
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-0.4.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="http://python-evdev.readthedocs.org/"
+SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/python-evdev/python-evdev-0.4.5.ebuild b/dev-python/python-evdev/python-evdev-0.4.5.ebuild
new file mode 100644
index 000000000000..d3895d99c58a
--- /dev/null
+++ b/dev-python/python-evdev/python-evdev-0.4.5.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for evdev bindings"
+HOMEPAGE="http://python-evdev.readthedocs.org/"
+SRC_URI="https://github.com/gvalkov/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"