summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-14 14:49:47 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-14 14:55:43 +0100
commit0635631bfe51bab811bafc8561174309b2e8a175 (patch)
tree608e56ee4ef108e4047c5b87e6ae95ef4ae7a32a /dev-python/python-dotenv
parentsys-kernel/gentoo-kernel-bin: Bump to 5.10.174 (diff)
downloadgentoo-0635631bfe51bab811bafc8561174309b2e8a175.tar.gz
gentoo-0635631bfe51bab811bafc8561174309b2e8a175.tar.bz2
gentoo-0635631bfe51bab811bafc8561174309b2e8a175.zip
dev-python/python-dotenv: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-dotenv')
-rw-r--r--dev-python/python-dotenv/Manifest1
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.21.1-r1.ebuild44
-rw-r--r--dev-python/python-dotenv/python-dotenv-0.21.1.ebuild41
3 files changed, 0 insertions, 86 deletions
diff --git a/dev-python/python-dotenv/Manifest b/dev-python/python-dotenv/Manifest
index 901c5bfe42ce..33686de53205 100644
--- a/dev-python/python-dotenv/Manifest
+++ b/dev-python/python-dotenv/Manifest
@@ -1,2 +1 @@
-DIST python-dotenv-0.21.1.tar.gz 35930 BLAKE2B e89b88754406464c7d9493d8824147c1b3862a1f1c9a723ddd0cec9c053b5772fe2f5d55fac0e979a3ffc5d717ec22ceb45064ed45f58f2a3c12c1018ebe2f47 SHA512 30bbff6c4d95ee3e58d0ce895fd9bcceef52f59f66060bcbc66460bb5fff977760d168a09415a6a52587ad560b892da60fafa5824a6634ba3202d07243d2ac8b
DIST python-dotenv-1.0.0.tar.gz 37399 BLAKE2B cc5a4b810fae2a79e091a9523738be37ba030c29a373f375f2d413396f56d0606b77febddfba82085f94abc151e86b3a8d4719899e4e80e9956bea3989569dbd SHA512 8fc14eb07d8fb5e4cb4a83338aac1009aaa0715b3e7438b4ac8ee7da0ad5f7cf6b05121a685d05af7f03828ab39df61382cfbc5e95c6708246d1f400fe10d250
diff --git a/dev-python/python-dotenv/python-dotenv-0.21.1-r1.ebuild b/dev-python/python-dotenv/python-dotenv-0.21.1-r1.ebuild
deleted file mode 100644
index 0daaef339c0d..000000000000
--- a/dev-python/python-dotenv/python-dotenv-0.21.1-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-# Re-add pypy3 after https://bugs.gentoo.org/729958
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Manage .env files"
-HOMEPAGE="https://github.com/theskumar/python-dotenv"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-
-# Requirement <dev-python/sh-2 has an upstream ticket:
-# https://github.com/theskumar/python-dotenv/issues/450
-DEPEND="
- test? (
- >=dev-python/click-5[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- <dev-python/sh-2[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGELOG.md README.md )
-
-distutils_enable_tests pytest
-
-python_install() {
- distutils-r1_python_install
- ln -s dotenv "${D}$(python_get_scriptdir)"/python-dotenv || die
-}
-
-src_install() {
- distutils-r1_src_install
-
- # Avoid collision with dev-ruby/dotenv (bug #798648)
- mv "${ED}"/usr/bin/{,python-}dotenv || die
-}
diff --git a/dev-python/python-dotenv/python-dotenv-0.21.1.ebuild b/dev-python/python-dotenv/python-dotenv-0.21.1.ebuild
deleted file mode 100644
index 8f180df1ab98..000000000000
--- a/dev-python/python-dotenv/python-dotenv-0.21.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( pypy3 python3_{9..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Manage .env files"
-HOMEPAGE="https://github.com/theskumar/python-dotenv"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- test? (
- >=dev-python/click-5[${PYTHON_USEDEP}]
- <dev-python/sh-2[${PYTHON_USEDEP}]
- >=dev-python/sh-1.09[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGELOG.md README.md )
-
-distutils_enable_tests pytest
-
-python_install() {
- distutils-r1_python_install
- ln -s dotenv "${D}$(python_get_scriptdir)"/python-dotenv || die
-}
-
-src_install() {
- distutils-r1_src_install
-
- # Avoid collision with dev-ruby/dotenv (bug #798648)
- mv "${ED}"/usr/bin/{,python-}dotenv || die
-}