summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-digest
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-digest')
-rw-r--r--dev-python/python-digest/Manifest1
-rw-r--r--dev-python/python-digest/files/python-digest-1.7-unittest.patch9
-rw-r--r--dev-python/python-digest/metadata.xml13
-rw-r--r--dev-python/python-digest/python-digest-1.7-r1.ebuild28
4 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/python-digest/Manifest b/dev-python/python-digest/Manifest
new file mode 100644
index 000000000000..835c783335a0
--- /dev/null
+++ b/dev-python/python-digest/Manifest
@@ -0,0 +1 @@
+DIST python-digest-1.7.tar.gz 10073 SHA256 cda2673e208e95c222b26b8b7717a356d2688e57391c7bd5a77154015e83be45 SHA512 15bfdb8e42275bc8f7fbc10f6f8bcd109852c57b77e98c8c2251784278fb135db494b0224341d34626ad49ea4db2a8803b2eb89d70d88b704819f4e6ca10f7e1 WHIRLPOOL 9b6002b2df7529db3f186a4c81803f8bacd8d14bb8a84b88ece71e36f21e38bd7af3c1394ac427ccd790bd68478c1acecc72b956d7993857eb604356c2b57f0c
diff --git a/dev-python/python-digest/files/python-digest-1.7-unittest.patch b/dev-python/python-digest/files/python-digest-1.7-unittest.patch
new file mode 100644
index 000000000000..e3abe0b77c8f
--- /dev/null
+++ b/dev-python/python-digest/files/python-digest-1.7-unittest.patch
@@ -0,0 +1,9 @@
+--- python_digest/tests.py.orig 2012-04-25 11:48:30.212254059 +0200
++++ python_digest/tests.py 2012-04-25 11:48:58.371585156 +0200
+@@ -486,3 +486,6 @@
+ for c in s:
+ self.assertFalse(fs.character(c))
+ self.assertRaises(ValueError, fs.close)
++
++if __name__ == "__main__":
++ unittest.main()
diff --git a/dev-python/python-digest/metadata.xml b/dev-python/python-digest/metadata.xml
new file mode 100644
index 000000000000..e30ccd6a26bb
--- /dev/null
+++ b/dev-python/python-digest/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-digest</remote-id>
+ <remote-id type="bitbucket">akoha/python-digest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-digest/python-digest-1.7-r1.ebuild b/dev-python/python-digest/python-digest-1.7-r1.ebuild
new file mode 100644
index 000000000000..73528d95a5ff
--- /dev/null
+++ b/dev-python/python-digest/python-digest-1.7-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python library to aid in implementing HTTP Digest Authentication"
+HOMEPAGE="http://pypi.python.org/pypi/python-digest/ https://bitbucket.org/akoha/python-digest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="amd64 x86"
+IUSE="test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+PATCHES=( "${FILESDIR}"/${P}-unittest.patch )
+
+python_test() {
+ "${PYTHON}" ${PN/-/_}/tests.py || die "Tests failed under ${EPYTHON}"
+}