summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-20 07:19:57 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-20 08:44:59 +0100
commit35c05217d410d6f4c19840a446122e7ac2489fa2 (patch)
tree73cffbb28c87e8f2bfee2999608d418eddc830ba /dev-python/python-debian
parentdev-python/numpy: Bump to 1.23.5 (diff)
downloadgentoo-35c05217d410d6f4c19840a446122e7ac2489fa2.tar.gz
gentoo-35c05217d410d6f4c19840a446122e7ac2489fa2.tar.bz2
gentoo-35c05217d410d6f4c19840a446122e7ac2489fa2.zip
dev-python/python-debian: Bump to 0.1.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-debian')
-rw-r--r--dev-python/python-debian/Manifest1
-rw-r--r--dev-python/python-debian/python-debian-0.1.49.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/python-debian/Manifest b/dev-python/python-debian/Manifest
index 31422edc4d80..0d9e67906fa8 100644
--- a/dev-python/python-debian/Manifest
+++ b/dev-python/python-debian/Manifest
@@ -1 +1,2 @@
DIST python-debian_0.1.48.tar.xz 189096 BLAKE2B 3b273f1e90069e00a93aeb9c2333d20d479b057613c93325344f42a73230bd569160a487a25d1c7f90f7f00f42feeab55c9850cf44121e1ca423cd1f40a991a4 SHA512 85bd12ce8ade9b43d502bd60ac1ac826d9a81b5bf32262ff9377b4ba5a1c95306683098d10a64fd6a1331ed7eb44a7fb09ad90f0ee6c885d69ea16f85c4eda59
+DIST python-debian_0.1.49.tar.xz 191388 BLAKE2B 590e6f7877684caaa5a74f06d335bcf7808960968209cf18bb2cec7e81f33a3b0ff458bbe30264ae5fc015de9357dddb1522b5fd93bf33d0a7fabef1b7dd98f9 SHA512 201ceecdd8c1d3dc0cca0f661407bcfb825a1cba07c528858cc1123ab16afe0df50e338c8cd82ea24230812a9cc136220bd4f0dccbac19ad53efe48eaa25cf6f
diff --git a/dev-python/python-debian/python-debian-0.1.49.ebuild b/dev-python/python-debian/python-debian-0.1.49.ebuild
new file mode 100644
index 000000000000..b1cc03134cca
--- /dev/null
+++ b/dev-python/python-debian/python-debian-0.1.49.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2011-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python modules to work with Debian-related data formats"
+HOMEPAGE="
+ https://salsa.debian.org/python-debian-team/python-debian/
+ https://pypi.org/project/python-debian/
+"
+SRC_URI="mirror://debian/pool/main/${PN::1}/${PN}/${PN}_${PV}.tar.xz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ app-arch/dpkg
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # See debian/rules.
+ sed -e "s/__CHANGELOG_VERSION__/${PV}/" lib/debian/_version.py.in \
+ > lib/debian/_version.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # See debian/rules.
+ "${EPYTHON}" lib/debian/doc-debtags > README.debtags || die
+}
+
+python_test() {
+ epytest --doctest-modules lib
+}