summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-09 17:50:00 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-09 17:59:58 +0100
commit70dfe1317166ce10283ccf52daabc96737ce9bf5 (patch)
treef3df82f0c5e5ddd92a75b6db8e3c755b47e541e9 /dev-python/pytest-rerunfailures
parentdev-python/ipdb: Bump to 0.13.13 (diff)
downloadgentoo-70dfe1317166ce10283ccf52daabc96737ce9bf5.tar.gz
gentoo-70dfe1317166ce10283ccf52daabc96737ce9bf5.tar.bz2
gentoo-70dfe1317166ce10283ccf52daabc96737ce9bf5.zip
dev-python/pytest-rerunfailures: Bump to 11.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/Manifest1
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-11.1.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/Manifest b/dev-python/pytest-rerunfailures/Manifest
index 8e2f4997e8fc..c66b676127f3 100644
--- a/dev-python/pytest-rerunfailures/Manifest
+++ b/dev-python/pytest-rerunfailures/Manifest
@@ -1,2 +1,3 @@
DIST pytest-rerunfailures-11.1.1.tar.gz 17088 BLAKE2B f9906a40e37fe8710cdfcdbf4070cc0196097b63845d971e6bc47d5a80ee204dcaf63510a53de6498366c6b62c537a9ffe55485e146a7d04001141f276cdc126 SHA512 32b498fd1552f934785ac0f668d9c1c5e955dc0ffdb8a187f03d75fb7e1eafc0a322f0e57a6cc932b8ee639166a264b1dd16a34a83d93acae73129ce7e603cff
+DIST pytest-rerunfailures-11.1.2.tar.gz 17234 BLAKE2B c497fee173f09de42d605d092336105e7144aafcdcfe6cdfbe3df65e09c3ab5cf0bc2d42746662f792c832ac25538f3cd81dc97d6e01201b14b480cb0e2d3a46 SHA512 309a0d180a996ddb5d6eb0833e6abd107887bc17ca3003a2b02bbaf5a4cbd63012618ee293a2a80623ca327b46ce7a5cd53bb341de75e5670a62b84e7ce5f0bc
DIST pytest-rerunfailures-11.1.tar.gz 16681 BLAKE2B aa1e35659411bc9cc777253982d53b39a969fe1448990008e99903ca3bd2a675f07551ab806a0656b9ed329b519458c02e46dc8fa2f1e0f60be8e3b2457e48d1 SHA512 9a572faab4ee1907e829d38979a87c5eb24dc13edfbbd987801b610f67d0a5ce8743f2bdbe883bd247915e6ede6b73fceae9c4994774e74b1b1a192587829e05
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-11.1.2.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-11.1.2.ebuild
new file mode 100644
index 000000000000..5318792547f3
--- /dev/null
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-11.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="pytest plugin to re-run tests to eliminate flaky failures"
+HOMEPAGE="
+ https://github.com/pytest-dev/pytest-rerunfailures/
+ https://pypi.org/project/pytest-rerunfailures/
+"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=pytest_rerunfailures
+ epytest
+}