summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-14 05:17:40 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-14 05:57:05 +0100
commit58be03eb46de264ba98a1cbce6c92f8c781a7b1f (patch)
treede441f397a31a92a130be37ce935480d9fcf8da0 /dev-python/pytest-regressions
parentdev-python/translate-toolkit: Bump to 3.8.1 (diff)
downloadgentoo-58be03eb46de264ba98a1cbce6c92f8c781a7b1f.tar.gz
gentoo-58be03eb46de264ba98a1cbce6c92f8c781a7b1f.tar.bz2
gentoo-58be03eb46de264ba98a1cbce6c92f8c781a7b1f.zip
dev-python/pytest-regressions: Bump to 2.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-regressions')
-rw-r--r--dev-python/pytest-regressions/Manifest1
-rw-r--r--dev-python/pytest-regressions/pytest-regressions-2.4.2.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pytest-regressions/Manifest b/dev-python/pytest-regressions/Manifest
index 5920267f38a8..62a2aa0cd3aa 100644
--- a/dev-python/pytest-regressions/Manifest
+++ b/dev-python/pytest-regressions/Manifest
@@ -1 +1,2 @@
DIST pytest-regressions-2.4.1.tar.gz 110863 BLAKE2B 0c2995d475fd194f318a3f1de28942a9711f0a194bec94f863b92fe16af801a6da50a7a7e825af65c581aed1c978c6be7b18252a08841919751f55e83f6633ea SHA512 0f4a0b4735804b4975cd643d0a55262b67f8583e41f292f2b519cc0c99a5c36a6f5abe49a1084fe4e919cb622d90fd21e0374b718a6cd7cfd44b48395dd9ed1a
+DIST pytest-regressions-2.4.2.tar.gz 111030 BLAKE2B 4c1d3ce9a210b6156e046b91688aec6ecab53d4719b5b556cdf6773a6af891352f7f213259140fdb7234f2528dbad5bf5c4ed43431aee94bfd373dd1839c1231 SHA512 f5abcc09da7a466e446329737d4926d3c7c9ac274e1087e6f746fe263b4cfd1b0f4b8870eea3d22b1209a0d5ead7b7169e700d10f3f29bb978e12a33511b1f51
diff --git a/dev-python/pytest-regressions/pytest-regressions-2.4.2.ebuild b/dev-python/pytest-regressions/pytest-regressions-2.4.2.ebuild
new file mode 100644
index 000000000000..4bb932d10ccd
--- /dev/null
+++ b/dev-python/pytest-regressions/pytest-regressions-2.4.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Easy to use fixtures to write regression tests"
+HOMEPAGE="
+ https://github.com/ESSS/pytest-regressions/
+ https://pypi.org/project/pytest-regressions/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-datadir[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/sphinx_rtd_theme
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=()
+ if ! has_version "dev-python/matplotlib[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py::test_image_regression
+ )
+ fi
+ if ! has_version "dev-python/numpy[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/test_ndarrays_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pandas[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_filenames.py::test_foo
+ tests/test_filenames.py::TestClass::test_foo
+ tests/test_filenames.py::TestClassWithIgnoredName::test_foo
+ )
+ EPYTEST_IGNORE+=(
+ tests/test_dataframe_regression.py
+ tests/test_num_regression.py
+ )
+ fi
+ if ! has_version "dev-python/pillow[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ tests/test_image_regression.py
+ )
+ fi
+
+ epytest
+}