summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-23 06:52:29 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-23 07:07:10 +0200
commit875baf4e221e9fba65d84e86563d0e12b83f4fae (patch)
treeecf9d5da5e99dc5f5a7e80c40da9c8f20737df30 /dev-python/pytest-httpserver
parentdev-util/stripe-mock: Bump to 0.163.0 (diff)
downloadgentoo-875baf4e221e9fba65d84e86563d0e12b83f4fae.tar.gz
gentoo-875baf4e221e9fba65d84e86563d0e12b83f4fae.tar.bz2
gentoo-875baf4e221e9fba65d84e86563d0e12b83f4fae.zip
dev-python/pytest-httpserver: Bump to 1.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpserver')
-rw-r--r--dev-python/pytest-httpserver/Manifest1
-rw-r--r--dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pytest-httpserver/Manifest b/dev-python/pytest-httpserver/Manifest
index 02c9b7c46acc..039aa0b96c1e 100644
--- a/dev-python/pytest-httpserver/Manifest
+++ b/dev-python/pytest-httpserver/Manifest
@@ -1,2 +1,3 @@
DIST pytest-httpserver-1.0.6.gh.tar.gz 83737 BLAKE2B d0db97227bcb3336a4bd944cf26e2d3e96132baee5991cdff901a1f546174e977b6472458911fc6b92bb13b6d3dae499e0bf3507be265385601e838c4781f0a3 SHA512 5eacfbf159f3a09d73f54da8f3ff885b8d2138e430af27df6039a30e63d7ebcbcf088efe8e7fa56ed50b66ea5b7e3ad7a61c0e8a57d5cb100c2a063df7b6f5c4
DIST pytest_httpserver-1.0.7.tar.gz 60065 BLAKE2B a3e523adfa5597b8d2a0850c0f3992fc829cf371fef812e7386f256acd4ae50925bc5c5d2ea2f77fdd4b8499357c060a64076fc8cca9d66bb689028715ac1422 SHA512 21fb81350ad24e0e59322d7530025e0859c59c62ef0eb6248dbd044ce893fd4c5fa0bc691741578a3d7fa6801dc5c80bc56b10baafff2c1abd480d4c994c93c7
+DIST pytest_httpserver-1.0.8.tar.gz 60126 BLAKE2B 9da65074aeca7de6a91c7afab7ac83ec8724c0595efe4abe7f3e2951ac37137c48a770ea1b5baeeb7484d647c1a03c20c86ad4de7627fb63beef174a2f7c3925 SHA512 5acff56b1c250c190da6466d398c10f206a24fe4112628ba4ec56bb2e23e21408b13d22ab6ad428e7ad7e685d7f2e73d5fc4b7afe86e7cb88d844a6e8e1a6bb4
diff --git a/dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild b/dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild
new file mode 100644
index 000000000000..842fa75ebaed
--- /dev/null
+++ b/dev-python/pytest-httpserver/pytest-httpserver-1.0.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="HTTP server for pytest to test HTTP clients"
+HOMEPAGE="
+ https://github.com/csernazs/pytest-httpserver/
+ https://pypi.org/project/pytest-httpserver/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # tests from building release artifacts
+ tests/test_release.py
+ )
+
+ epytest -p no:localserver
+}