summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-13 06:45:26 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-13 07:05:32 +0100
commit37f575e79562fe26a21f900ca0af14e950476a91 (patch)
treef01e52ab466dee625ffbfc0a0d68dc1ef0960982 /dev-python/pytest-forked
parentdev-python/imageio: Bump to 2.25.1 (diff)
downloadgentoo-37f575e79562fe26a21f900ca0af14e950476a91.tar.gz
gentoo-37f575e79562fe26a21f900ca0af14e950476a91.tar.bz2
gentoo-37f575e79562fe26a21f900ca0af14e950476a91.zip
dev-python/pytest-forked: Bump to 1.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-forked')
-rw-r--r--dev-python/pytest-forked/Manifest1
-rw-r--r--dev-python/pytest-forked/pytest-forked-1.6.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pytest-forked/Manifest b/dev-python/pytest-forked/Manifest
index d7573e6bb5a9..5ca9eb13d118 100644
--- a/dev-python/pytest-forked/Manifest
+++ b/dev-python/pytest-forked/Manifest
@@ -1 +1,2 @@
DIST pytest-forked-1.4.0.tar.gz 10197 BLAKE2B 7a6ec42f7ad1323eea243739a9186fb87eac3016afef844ec39a6e3fd55f7d40b1410fcc27074624f8468e6dabddffcc22ea0597bbbd898fab71c82c06e25b46 SHA512 ba402aec6dbec7a94815913192a49390b637a123d3557f48d809ae2e871e9e0cff8f9d0feb99e2bd06fe9486520b5e539f397d39475a720f8283b1bd21c751c7
+DIST pytest-forked-1.6.0.tar.gz 9977 BLAKE2B cfef0ce10c9690894de14ed503ba74244c99c235838039f800b2c26430258e62c98fcc49d9e59b240b2ceee79e467bfbf0da5c96bc4a2d59770ceadd5021a5a9 SHA512 28fedc56fd696a4e7cf528034056849eff14094d5e7f0e94c7c477a7e91e42c08988769cf6f40d25fe8823399e552253cde2198121dd6a9e475fb6a8ce358cad
diff --git a/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild b/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
new file mode 100644
index 000000000000..46e067fc3b0f
--- /dev/null
+++ b/dev-python/pytest-forked/pytest-forked-1.6.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Run tests in isolated forked subprocesses"
+HOMEPAGE="
+ https://pypi.org/project/pytest-forked/
+ https://github.com/pytest-dev/pytest-forked/
+"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+# Please do not RDEPEND on pytest; this package won't do anything
+# without pytest installed, and there is no reason to force older
+# implementations on pytest.
+RDEPEND="
+ dev-python/py[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky
+}