summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-14 20:42:53 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-14 20:42:53 +0300
commit90889c8a4ad7f71decb54a51171c93d9797ae310 (patch)
tree82b1dc0cb802ccae4472c0653f5e70f683a819e5 /dev-python/pytest-env
parentdev-python/pytest-describe: Use PEP517 (diff)
downloadgentoo-90889c8a4ad7f71decb54a51171c93d9797ae310.tar.gz
gentoo-90889c8a4ad7f71decb54a51171c93d9797ae310.tar.bz2
gentoo-90889c8a4ad7f71decb54a51171c93d9797ae310.zip
dev-python/pytest-env: EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-env')
-rw-r--r--dev-python/pytest-env/pytest-env-0.6.2-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/pytest-env/pytest-env-0.6.2-r1.ebuild b/dev-python/pytest-env/pytest-env-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..0506fe16260b
--- /dev/null
+++ b/dev-python/pytest-env/pytest-env-0.6.2-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin that allows you to add environment variables"
+HOMEPAGE="https://github.com/MobileDynasty/pytest-env"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"