summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-10 19:17:40 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-10 19:18:10 +0300
commiteaa225139f21017a650917bd0409e4946d715b58 (patch)
tree78e26755139720abd1f1688e3066fc4c514f5467 /dev-python/pytest-datadir
parentnet-vpn/vpnc-scripts: bump version to 20220510 (diff)
downloadgentoo-eaa225139f21017a650917bd0409e4946d715b58.tar.gz
gentoo-eaa225139f21017a650917bd0409e4946d715b58.tar.bz2
gentoo-eaa225139f21017a650917bd0409e4946d715b58.zip
dev-python/pytest-datadir: enable py3.11, EAPI=8, PEP517
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-datadir')
-rw-r--r--dev-python/pytest-datadir/pytest-datadir-1.3.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pytest-datadir/pytest-datadir-1.3.1-r1.ebuild b/dev-python/pytest-datadir/pytest-datadir-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..cf8db19c0287
--- /dev/null
+++ b/dev-python/pytest-datadir/pytest-datadir-1.3.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin for manipulating test data directories and files"
+HOMEPAGE="https://github.com/gabrielcnr/pytest-datadir"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Do not install license to /usr
+ sed -e '/data_files/d' -i setup.py || die
+
+ distutils-r1_src_prepare
+}