summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-04 07:35:19 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-04 07:51:27 +0200
commit7e7987081fae7fc45936f58a0840df0aac7eab70 (patch)
tree502eb2914c79fe1df01638ebd6f1d9ebe871227d /dev-python/pytest-datadir
parentdev-python/psycopg: Bump to 2.9.9 (diff)
downloadgentoo-7e7987081fae7fc45936f58a0840df0aac7eab70.tar.gz
gentoo-7e7987081fae7fc45936f58a0840df0aac7eab70.tar.bz2
gentoo-7e7987081fae7fc45936f58a0840df0aac7eab70.zip
dev-python/pytest-datadir: Bump to 1.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-datadir')
-rw-r--r--dev-python/pytest-datadir/Manifest1
-rw-r--r--dev-python/pytest-datadir/pytest-datadir-1.5.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pytest-datadir/Manifest b/dev-python/pytest-datadir/Manifest
index b31186d8b5e9..c8ef0907a149 100644
--- a/dev-python/pytest-datadir/Manifest
+++ b/dev-python/pytest-datadir/Manifest
@@ -1 +1,2 @@
DIST pytest-datadir-1.4.1.tar.gz 7862 BLAKE2B 6ecd0ba76706c2fedf5964b3f6476176b2eb858fff9207b6286f6235d13c173f62fd03abeab2f5e5fd31506ee436c731d9786fe7937620bb1de08bb50f7b492d SHA512 e9a301004275235787de11242fe987665e4fcc89ca2d1168b27686f4d1506e506bdd517658edcbf2aca97b28dcb1869653e16412157b8ef313c1d4146f8cf4d8
+DIST pytest-datadir-1.5.0.tar.gz 8821 BLAKE2B 68250c0100492c501b2752930cc6668a50233a7be08eeec56b99993c2bc21a13a2f6e2a2bd066dd52d58d219cd63b22f0a63fe51b7e16f80dd919f835994b5cd SHA512 6a91bbd7d1ac133c08d5aad3d9b7fa55b9c81dfea1ca5c18f8c9a90a60db4a1e5c09584a4ad0d420007162c507b91d6769a692057ef5be8eb44af6cbd5704f0c
diff --git a/dev-python/pytest-datadir/pytest-datadir-1.5.0.ebuild b/dev-python/pytest-datadir/pytest-datadir-1.5.0.ebuild
new file mode 100644
index 000000000000..103e6d22cdc1
--- /dev/null
+++ b/dev-python/pytest-datadir/pytest-datadir-1.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for manipulating test data directories and files"
+HOMEPAGE="
+ https://github.com/gabrielcnr/pytest-datadir/
+ https://pypi.org/project/pytest-datadir/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest