summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-21 20:29:19 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-21 20:41:08 +0300
commitfaef802a6f0d88da0507d77015fcffeb1959db5c (patch)
tree797c0164754c72a974e8e38481437c8dd0c0628c /dev-python/pytest-check
parentdev-python/jsonschema: add 4.14.0 (diff)
downloadgentoo-faef802a6f0d88da0507d77015fcffeb1959db5c.tar.gz
gentoo-faef802a6f0d88da0507d77015fcffeb1959db5c.tar.bz2
gentoo-faef802a6f0d88da0507d77015fcffeb1959db5c.zip
dev-python/pytest-check: add 1.0.7
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-check')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/pytest-check-1.0.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
index cecdf0eb86a2..788eff12befc 100644
--- a/dev-python/pytest-check/Manifest
+++ b/dev-python/pytest-check/Manifest
@@ -1 +1,2 @@
DIST pytest-check-1.0.5.gh.tar.gz 10296 BLAKE2B 8eac4185e223736181e9465c8d4220874553d9e12d068069b40e7a1ea150c93d533facc8b3483649eb00da9a2286544c58e2c530138f830155466e3bb71aeedc SHA512 73c42c98639bf3026e62f5c2c9ce404ddbd4711afa1ff31d207886329a45cfc1c0f263dd3321a9b203b9b68cad87f76bbff61894ed7a67d0bd26e7d0d20ede21
+DIST pytest-check-1.0.7.tar.gz 12980 BLAKE2B ebcd8aed8ca20c67c9683a763da181981e0814bb10aaacd803f827610a3f33730655dfa684fc273b347a2542bc6c3f20e8253cc17d8a4bbe05c9938076784e4a SHA512 5cf5b25bc264475d475433f1418376c933335dbc7c765419cb00e6143a18d0ef560f027d472c21e2a339cee5111c487d7edd5b5cd149315e9d7cca956b928959
diff --git a/dev-python/pytest-check/pytest-check-1.0.7.ebuild b/dev-python/pytest-check/pytest-check-1.0.7.ebuild
new file mode 100644
index 000000000000..31947e866cc2
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-1.0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest_check/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Fix expecting result in case pytest throws deprecation warnings
+ sed -e '/fnmatch_lines/s/\* /\*/g' \
+ -e '/fnmatch_lines/s/ \*/\*/g' \
+ -i tests/test_check.py || die
+
+ distutils-r1_src_prepare
+}