summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-06 04:17:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-06 04:26:55 +0100
commitc254bd5bf598b3bace3bac449d910efb0c6a24e8 (patch)
treef606d8dc1a870cc6ae601dc3baa7617d91aa6635 /dev-python/pysnmp
parentdev-python/aiohttp: Bump to 3.11.10 (diff)
downloadgentoo-c254bd5bf598b3bace3bac449d910efb0c6a24e8.tar.gz
gentoo-c254bd5bf598b3bace3bac449d910efb0c6a24e8.tar.bz2
gentoo-c254bd5bf598b3bace3bac449d910efb0c6a24e8.zip
dev-python/pysnmp: Bump to 7.1.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pysnmp')
-rw-r--r--dev-python/pysnmp/Manifest1
-rw-r--r--dev-python/pysnmp/pysnmp-7.1.15.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/pysnmp/Manifest b/dev-python/pysnmp/Manifest
index 1eec5aee6579..7b88ea589ad8 100644
--- a/dev-python/pysnmp/Manifest
+++ b/dev-python/pysnmp/Manifest
@@ -1,2 +1,3 @@
DIST pysnmp-7.1.13.tar.gz 378397 BLAKE2B e10c50b85f604211f0b96199150fa3580c40e7acac8670fe1419d2095fd8bf479ce0c4ff1ef77a69f2c178e0c9f8b8ccdc72ee75acb3153cfc428d398bf0051e SHA512 630dd81ea6db5c7b75564031c8382408fda6a4625fa9f694a57f9f3570c70293de2560f3b1fb607d929d604731633dcbb9e6fd9cb9a8b189ef339257a3c16569
DIST pysnmp-7.1.14.tar.gz 380516 BLAKE2B 972426164598d1579b174cadae84e610cfe0a8c5574c25cee8ea8dca804021900818a2d66c89df6d185257050f88625a1cdddcfcc5b43fcf03d053523bdae9cd SHA512 edbce007d53bd0a876bef7ee2b0286b46f6c6a33b9da89a82d737580bc31a34197a9ad490e4d09441984ccc89b61110bfea2a9f563a84b081d4127a29bee1c80
+DIST pysnmp-7.1.15.tar.gz 380504 BLAKE2B a0bc0d321c88fd3ab45b32be590172d67d721dacbd10effa4e535db907cd39ca191413007b2c1ff2f42553049b4ca4472abdde72bef541685edad474597e8e31 SHA512 8e24d5e7563c6299dbeaeb066a4045c44f860ed8fb9565bf621b3d6c99301c8a6f6e8661ecbb3285b4032b415bec3cbbe4969b856a22fad932ce5371fc019144
diff --git a/dev-python/pysnmp/pysnmp-7.1.15.ebuild b/dev-python/pysnmp/pysnmp-7.1.15.ebuild
new file mode 100644
index 000000000000..8e1fe159f72f
--- /dev/null
+++ b/dev-python/pysnmp/pysnmp-7.1.15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python SNMP library"
+HOMEPAGE="
+ https://pypi.org/project/pysnmp/
+ https://github.com/lextudio/pysnmp/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~sparc ~x86"
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/cryptography-43.0.1[${PYTHON_USEDEP}]
+ >=dev-python/pyasn1-0.4.8[${PYTHON_USEDEP}]
+ >=dev-python/pysmi-1.5.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+# TODO
+# distutils_enable_sphinx docs/source dev-python/furo dev-python/sphinx-copybutton dev-python/sphinx-sitemap
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/smi/manager/test_mib-tree-inspection.py::test_getNodeName_by_symbol_description_with_module_name_2
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ mibdump CISCO-ENHANCED-IPSEC-FLOW-MIB.py || die
+ mibdump LEXTUDIO-TEST-MIB || die
+ mibdump NET-SNMP-EXAMPLES-MIB || die
+ mibdump IF-MIB || die
+ epytest -p asyncio
+}