summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernd Waibel <waebbl-gentoo@posteo.net>2022-08-22 07:23:41 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-23 13:50:24 +0200
commit3434de255e4fa1b40b62abe9774e8696bb47a661 (patch)
tree0c6019fb9938e0a90823c953ef909beedbb99a94 /dev-python/pyside6
parentdev-python/pyside6-tools: remove unused patch(es) (diff)
downloadgentoo-3434de255e4fa1b40b62abe9774e8696bb47a661.tar.gz
gentoo-3434de255e4fa1b40b62abe9774e8696bb47a661.tar.bz2
gentoo-3434de255e4fa1b40b62abe9774e8696bb47a661.zip
dev-python/pyside6: install designer plugin to proper destination
Closes: https://bugs.gentoo.org/865363 Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/26957 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/pyside6')
-rw-r--r--dev-python/pyside6/files/pyside6-6.3.1-fix-designer-plugin-install-location.patch16
-rw-r--r--dev-python/pyside6/pyside6-6.3.1-r1.ebuild (renamed from dev-python/pyside6/pyside6-6.3.1.ebuild)5
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/pyside6/files/pyside6-6.3.1-fix-designer-plugin-install-location.patch b/dev-python/pyside6/files/pyside6-6.3.1-fix-designer-plugin-install-location.patch
new file mode 100644
index 000000000000..b7d1c2b31553
--- /dev/null
+++ b/dev-python/pyside6/files/pyside6-6.3.1-fix-designer-plugin-install-location.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/865363
+
+From 109d7bbec01870f8e944a9cde09d3e2f70e13e0d Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl-gentoo@posteo.net>
+Date: Mon, 22 Aug 2022 07:10:35 +0200
+Subject: [PATCH] fix designer plugin install location
+
+Signed-off-by: Bernd Waibel <waebbl-gentoo@posteo.net>
+--- a/plugins/designer/CMakeLists.txt
++++ b/plugins/designer/CMakeLists.txt
+@@ -53,4 +53,4 @@ target_link_libraries(PySidePlugin PRIVATE
+ Qt::Widgets
+ ${SHIBOKEN_PYTHON_LIBRARIES})
+
+-install(TARGETS PySidePlugin LIBRARY DESTINATION "plugins/designer")
++install(TARGETS PySidePlugin LIBRARY DESTINATION "lib${LIB_SUFFIX}/qt6/plugins/designer")
diff --git a/dev-python/pyside6/pyside6-6.3.1.ebuild b/dev-python/pyside6/pyside6-6.3.1-r1.ebuild
index 09cbf24f7b1e..a94b8db45b4b 100644
--- a/dev-python/pyside6/pyside6-6.3.1.ebuild
+++ b/dev-python/pyside6/pyside6-6.3.1-r1.ebuild
@@ -98,6 +98,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${P}-no-strip.patch"
+ "${FILESDIR}/${P}-fix-designer-plugin-install-location.patch"
)
src_configure() {
@@ -153,6 +154,10 @@ src_configure() {
-DCMAKE_DISABLE_FIND_PACKAGE_Qt6Widgets=$(usex !widgets)
#-DCMAKE_DISABLE_FIND_PACKAGE_Qt6WinExtras=yes
-DCMAKE_DISABLE_FIND_PACKAGE_Qt6Xml=$(usex !xml)
+ # try to avoid pre-stripping
+ -DQFP_NO_OVERRIDE_OPTIMIZATION_FLAGS=yes
+ -DQFP_NO_STRIP=yes
+
)
pyside6_configure() {