summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-15 08:36:57 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-15 08:38:57 +0300
commit6b87b4559802a2fb82a0a4a01120800b7b5d420d (patch)
treef456258638be41b4e98d2879f11072e2c825e847 /dev-python/pyrqlite
parentdev-python/txAMQP: enable py3.10, enable tests (diff)
downloadgentoo-6b87b4559802a2fb82a0a4a01120800b7b5d420d.tar.gz
gentoo-6b87b4559802a2fb82a0a4a01120800b7b5d420d.tar.bz2
gentoo-6b87b4559802a2fb82a0a4a01120800b7b5d420d.zip
dev-python/pyrqlite: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/pyrqlite')
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-2.1.ebuild b/dev-python/pyrqlite/pyrqlite-2.1.ebuild
index c5e0a6a8cb99..c3171044ea3d 100644
--- a/dev-python/pyrqlite/pyrqlite-2.1.ebuild
+++ b/dev-python/pyrqlite/pyrqlite-2.1.ebuild
@@ -2,8 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python client for rqlite"
@@ -14,9 +14,9 @@ SRC_URI="https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
+
BDEPEND="test? ( dev-db/rqlite )"
+
PATCHES=("${DISTDIR}/${P}-python3.10-test_support.patch")
distutils_enable_tests pytest