summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-24 11:55:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-24 13:09:19 +0200
commit27fbb3a4337a6c38c24a5e420f240c48b646071d (patch)
tree5cb05004ee6984b13926b1132e98c2ac8dbb55c8 /dev-python/pypugjs
parentdev-python/sentry-sdk: Bump to 2.3.1 (diff)
downloadgentoo-27fbb3a4337a6c38c24a5e420f240c48b646071d.tar.gz
gentoo-27fbb3a4337a6c38c24a5e420f240c48b646071d.tar.bz2
gentoo-27fbb3a4337a6c38c24a5e420f240c48b646071d.zip
dev-python/pypugjs: Fix more pyproject.toml issues
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pypugjs')
-rw-r--r--dev-python/pypugjs/pypugjs-5.10.1-r1.ebuild (renamed from dev-python/pypugjs/pypugjs-5.10.1.ebuild)11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-python/pypugjs/pypugjs-5.10.1.ebuild b/dev-python/pypugjs/pypugjs-5.10.1-r1.ebuild
index db189115ef63..8d98fdb25de6 100644
--- a/dev-python/pypugjs/pypugjs-5.10.1.ebuild
+++ b/dev-python/pypugjs/pypugjs-5.10.1-r1.ebuild
@@ -9,7 +9,10 @@ PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 optfeature
DESCRIPTION="Pug (Jade) syntax adapter for Django, Jinja2 and Mako templates"
-HOMEPAGE="https://github.com/kakulukia/pypugjs"
+HOMEPAGE="
+ https://github.com/kakulukia/pypugjs/
+ https://pypi.org/project/pypugjs/
+"
SRC_URI="
https://github.com/kakulukia/pypugjs/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
@@ -38,6 +41,12 @@ distutils_enable_tests pytest
src_prepare() {
# poetry nonsense
sed -i -e 's:\^:>=:' pyproject.toml || die
+ # upstream hardcodes wrong version, and puts test dependencies
+ # in regular depenendencies, so discard the whole thing
+ sed -e "/version/s:5\.9\.12:${PV}:" \
+ -e 's:tool\.poetry\.dependencies:tool.poetry.group.ignored.dependencies:' \
+ -i pyproject.toml || die
+
distutils-r1_src_prepare
}