summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-15 05:13:13 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-15 05:16:52 +0200
commitc1b88e33083b55a0ca9a26131e13fc56531c3fd7 (patch)
tree31e0b01d07c8667426388d4f9870b41f1c1c96e8 /dev-python/pyproject-api
parentdev-python/cfn-lint: Bump to 0.77.9 (diff)
downloadgentoo-c1b88e33083b55a0ca9a26131e13fc56531c3fd7.tar.gz
gentoo-c1b88e33083b55a0ca9a26131e13fc56531c3fd7.tar.bz2
gentoo-c1b88e33083b55a0ca9a26131e13fc56531c3fd7.zip
dev-python/pyproject-api: Bump to 1.5.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyproject-api')
-rw-r--r--dev-python/pyproject-api/Manifest1
-rw-r--r--dev-python/pyproject-api/pyproject-api-1.5.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyproject-api/Manifest b/dev-python/pyproject-api/Manifest
index 2d16c660c2c7..695db7377edd 100644
--- a/dev-python/pyproject-api/Manifest
+++ b/dev-python/pyproject-api/Manifest
@@ -1 +1,2 @@
DIST pyproject_api-1.5.1.tar.gz 22081 BLAKE2B 53ee778b4e04cac2f16ecd054adc7fd86373d6402f80d485fe22457252684f774b6a5df23d08cf6c6b1f96964d6dc1b1cc9014415f3d9105ffbb09421f69a11e SHA512 31936d242861027ea892e86219f430371aae18631c92893cefc8fb8fc02315906857ee57e5412eed62bf584e0bd24cca7ba82471c0ac6a72c71e8e93b8285a3e
+DIST pyproject_api-1.5.2.tar.gz 21926 BLAKE2B 337fa749273273e0d4c761876ac1b9ec25c02ad206dd222790717dde44ad82409d5200b94c2b5d35984116b1c88cfa10b93c699e684ff51b3235b936e35fe0ee SHA512 ee12ec0dccce0130bca703886c40ac21802f58fb7683370592f9dabbf83366939f5032d7f55c6b712cfa4fa0cf34d88fc37a05eae9d811b34fe9c7377886b8d7
diff --git a/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild b/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild
new file mode 100644
index 000000000000..3bc4973c1714
--- /dev/null
+++ b/dev-python/pyproject-api/pyproject-api-1.5.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="API to interact with the python pyproject.toml based projects"
+HOMEPAGE="
+ https://github.com/tox-dev/pyproject-api/
+ https://pypi.org/project/pyproject-api/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-23.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/tomli-2.0.1[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+BDEPEND="
+ >=dev-python/hatch-vcs-0.3.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/pytest-mock-3.10[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.8[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.40[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires Python 2 installed
+ tests/test_frontend.py::test_can_build_on_python_2
+)