summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-24 08:31:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-24 09:01:58 +0200
commit416921a265b2aa9e6eae3411fd9dfacc5c516727 (patch)
tree39c62506fd3b7018f03b6d9b7cf88e998128abdb /dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.7.ebuild
parentdev-python/httpcore: Bump to 0.17.2 (diff)
downloadgentoo-416921a265b2aa9e6eae3411fd9dfacc5c516727.tar.gz
gentoo-416921a265b2aa9e6eae3411fd9dfacc5c516727.tar.bz2
gentoo-416921a265b2aa9e6eae3411fd9dfacc5c516727.zip
dev-python/pyopengl_accelerate: Bump to 3.1.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.7.ebuild')
-rw-r--r--dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.7.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.7.ebuild b/dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.7.ebuild
new file mode 100644
index 000000000000..eaea9eacd1a6
--- /dev/null
+++ b/dev-python/pyopengl_accelerate/pyopengl_accelerate-3.1.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=pyopengl-release-${PV}
+DESCRIPTION="Accelerate module for PyOpenGL"
+HOMEPAGE="
+ https://pyopengl.sourceforge.net/
+ https://github.com/mcfletch/pyopengl/
+ https://pypi.org/project/PyOpenGL-accelerate/"
+SRC_URI="
+ https://github.com/mcfletch/pyopengl/archive/release-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}/accelerate
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ rm src/*.c || die
+}
+
+python_test() {
+ cd "${T}" || die
+ epytest "${S}"/tests
+}